Lost cell service in Kissimmee Florida

  • 1
  • Question
  • Updated 1 year ago
I have been in Kissimmee Florida for a month and had cell service until today.  I am still getting texts, but can't phone out and calls aren't coming in.
Photo of Bev Christie

Bev Christie

  • 264 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of BobTheElectrician

BobTheElectrician

  • 67,236 Points 50k badge 2x thumb
Did you purchase a 30-day roaming add-on that might just have just expired? Roaming add-ons don't renew automatically. Texting sometimes lags a little behind voice and data service in this regard since all basic plans include international texting.

If that's not the case, try shutting down the phone, pulling out the SIM for a few minutes, then restarting to refresh your signal to the mothership. A further step you can try is to then manually choose AT&T as your provider in mobile networks preferences.
(Edited)
Photo of BobTheElectrician

BobTheElectrician

  • 67,236 Points 50k badge 2x thumb
Send them a private message on their Facebook page. AFAIK, you can only have one roaming add-on active at a time --- they don't stack and don't renew automatically.
Photo of David

David, Mobile Master

  • 93,460 Points 50k badge 2x thumb
Buying any of the Travel Add-ons only nets you a savings on your roaming fees, it does not change anything about the ability of the phone to roam. Without the Voice / Text / Data Add-on, you can still roam at pay-per-use prices. That your phone will not call out is an issue separate from the expiry or non-expiry of the travel add on.
Photo of Bev Christie

Bev Christie

  • 264 Points 250 badge 2x thumb

Thanks...that makes sense!!


Photo of Bev Christie

Bev Christie

  • 264 Points 250 badge 2x thumb
Bob, I just tried your final steps..missed them on the first reading and was able to correct the problem by manually hooking up to AT&T.  Thanks so much!!  Your great!!
Photo of BobTheElectrician

BobTheElectrician

  • 67,236 Points 50k badge 2x thumb
Glad it worked out for you. Just remember to restore that setting to Koodo when you return to Canada.