Login Issues

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: no longer relevant

I have already registered with the self serve options, I am no longer able to login. It continues to say that the website is not working or I have been redirected too many times. I have tried two devices and two browsers. I cannot use the mobile app as I need to provide myself permission to use it....
I have cleared the cookies, restarted browsers, blah blah blah... I'm out of ideas

When I was actually logged into the account I wasn't able to access any information about my account - no usage information, not the account number nothing. All it would allow me to do it change the email address, password and security question... I thought the telus mobile site we tedious but damn...
Photo of Colleen Riswold McDonald

Colleen Riswold McDonald

  • 70 Points
  • frustraided

Posted 2 years ago

  • 1
Photo of Tiz

Tiz

  • 4,604 Points 4k badge 2x thumb
It seems to be one of those time when you need to call *611 and talk to a Koodo rep.
Photo of Chadwick

Chadwick, Mobile Master

  • 33,072 Points 20k badge 2x thumb
Sometimes the website can be finicky. Its working fine for me so it could be an issue your not noticing as well. I would try again in the morning and if its still not working, Most likely contacting customer care is your best bet.
Photo of Melissa

Melissa, Employee

  • 11,748 Points 10k badge 2x thumb
Hey Colleen! Is there another email associated with your account? You can always try clearing the cookies/cache and try again.  Also, try logging in using this link http://koo.do/1sA1y6Q . Let us know if it works! 

This conversation is no longer open for comments or replies.