live in sask. i bought a new iphone 7 it was showing 4G LTE when I bought it. now it is showing 3G how do i fix it and get 4G LTE back

  • 1
  • Question
  • Updated 8 months ago
Photo of randy bakaluk

randy bakaluk

  • 110 Points 100 badge 2x thumb

Posted 8 months ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Maybe you just entered an area with weak LTE signal
Photo of randy bakaluk

randy bakaluk

  • 110 Points 100 badge 2x thumb
It reads this when I'm at home or anywhere in town
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
And where were you when you last saw LTE?
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Here is the coverage map
http://choosehappy.koodomobile.com/network?INTCMP=KMNew_ChooseHappy_OurNetwork_CompareCoverage

Click on the detailed coverage map link to see the details
(Edited)
Photo of randy bakaluk

randy bakaluk

  • 110 Points 100 badge 2x thumb
I live in s.e. Sask
Photo of Dinh

Dinh, Mobile Master

  • 32,518 Points 20k badge 2x thumb
Did you install any internet profile?, VPN or anything?

For iPhone, could you try to reset the network settings (Settings --> General --> Reset --> Reset network Settings) and see if it help.
Photo of randy bakaluk

randy bakaluk

  • 110 Points 100 badge 2x thumb
Just did that. Got. LTE but no 4G
Photo of Dinh

Dinh, Mobile Master

  • 32,518 Points 20k badge 2x thumb
LTE is 4G :) for Koodo, cheers
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
All LTE is 4G
Photo of randy bakaluk

randy bakaluk

  • 110 Points 100 badge 2x thumb
Thnx did not know that