LG quantum c900 unlocked phone on Koodo network?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

Bought an unlocked LG Quantum C900 a little while back off of kijiji. Originally, the phone was with the Bell network and the guy who sold it to me claimed to have the phone working with a Rogers SIM card. I myself have had it running perfectly with a Fido card.

In the midst of a switch now, and I'm wanting to switch to koodo (from Fido; not interested in a new contract). I go to a Koodo retailer and before I complete the switch, the customer service rep tries a Koodo SIM card in my phone to see if it works, and it doesn't. It recognized that there was a SIM card, but didnt recognize the network.

I got the rep to scan my IMEI to see (in their "database") if it will work on Koodo's network, and it says quote "Your phone should work with our network".

I then checked Koodo's handy dandy online-unlocked-smart-phone-network-compatibility-checker (link below), it says quote "Your smartphone is compatible with the Koodo network".

http://koodomobile.com/en/on/switch2k...

Can anyone enlighten me here? I really dont see why it shouldn't work. Any advice would be fantastic, thanks a bunch!
Photo of Lucas

Lucas

  • 170 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,506 Points 100k badge 2x thumb
I suspect that the phone is set to 2g/gsm only, but since it is a windows 7 phone I have no idea where you would need to look to find this setting.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,524 Points 100k badge 2x thumb
And after that you'll need to make sure to set up your APN settings to those of Koodo's (if it doesn't do it automatically) to be able to get Internet service.
Photo of MatB

MatB

  • 32,478 Points 20k badge 2x thumb
Phone was locked to Bell, it worked with Rogers/Fido SIM, if it didn't ask to enter MEIP code when you used Koodo SIM after you created Koodo APN like suggested by Paul, if OS is Win 7 like stated by Timo, to add APN go to Settings>Data connection should be on>Network selection should be automatic, tap add APN>sp.koodo.com,>user name/pw should be left blank and save, Airplane mode must be off, if still not working call 1-866-995-6636 X6 for more help
Photo of Lucas

Lucas

  • 170 Points 100 badge 2x thumb
Timo: it is running windows phone 7.8 if that makes a difference or not. Under the "cellular" option in the settings, I have the choice to set my highest connection speed between E or 3G. If you could be more specific about the setting you're telling me to modify maybe then I could give it a try.

Paul: I don't have any sort of data services with Fido, but I dont know if that makes a difference (too cheap for data and wouldn't use it enough; let's just say I'm an avid Wifi user lol). Perhaps since Koodo has the pay-per-use Data Server, maybe the apn will do the trick? But wont this only help with internet access and not regular service? That was the first thing I had in mind to try when I was at the Koodo kiosk, but I sadly had no Wifi around (lol) to be able to look up the apn.

Mat: What is an MEIP number? Is it the number needed to fully boot the phone when a "foreign" SIM is inside the phone? If so I am fully aware of what this screen is supposed to look like and it did not come up when I booted the phone (with the Koodo card in). However once it was booted, I had a new voicemail, which I found odd since I didnt have any with my Fido card in there (dont have voicemail at all). In addition to all this, when I go to "about" in the settings, there is definitely a SIM ID nunber which makes this whole thing that much more strange to me.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,506 Points 100k badge 2x thumb
Still doesn't help me much. I work a lot with android and ios but almost never deal with windows phone. Try this method I found online:
Steps:

Open the phone dialer
Punch in ##3282# – you will enter debug mode
Touch the ‘...’ at the bottom of the screen and click on ‘settings’
Now you should be able to touch and select either 2G or 3G, or leave it at ‘automatic’
Photo of Lucas

Lucas

  • 170 Points 100 badge 2x thumb
Just tried that, I will go visit Koodo today to try it out with one of their SIM cards and let you know how it works out (I switched it to automatic by the way, which it was at 2G only before, I assume this is what you were suggesting I do?)
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,506 Points 100k badge 2x thumb
That would be it. Rogers/fido has a 2G network, koodo/bell/telus don't.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,524 Points 100k badge 2x thumb
If you don't want data then ignore what I added just listen to Timo, he's got it
Photo of Lucas

Lucas

  • 170 Points 100 badge 2x thumb
Well, I went to koodo and tried the rep's SIM card (so I knew 100% that it was a valid, registered phone number), and sure enough it worked right away! So either changing the debug mode setting did the trick OR the other SIM i tried may not have been registered, cause I never saw it work on another phone. But in any case thanks for the help! :) I've successfully made the switch now
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,506 Points 100k badge 2x thumb
Glad to hear it. Welcome to Koodo!

This conversation is no longer open for comments or replies.