Keep loosing connection - not registered on network

  • 1
  • Question
  • Updated 1 year ago
  • Answered
We purchased an unlocked (SM-G800F) third party S5 mini from amazon.  It keeps loosing network connection to Koodoo even when the signal is strong.  Sometimes it connects to Koodoo and works OK, sometimes it shows R (roaming), but most of the time trying to dial out it says not registered on network, emergency calls only.  

The old SIM card came out of a Koodoo Iphone 5c, worked fine on that phone.  We replaced the SIM card with a brand new on, did not change.  Tried rebooting,different connection options (WCDMA/GSM auto connect, WCDMA only, GSM only).  Nothing seems to make a difference, very flaky connection.

My S5 and Moto G3 off amazon both work flawlessly, stay connected to Koodoo with same settings reliably.  As did the 3 iphones we had.

Tried to change the  phone to the new IMEI#, but the website would not accept it, tired several times.  The IMEI checks out OK under third party phones though (not stolen, and "should work" on Koodoo).  Does the IMEI require registration on the SIM card/ account/ # to stay connected to Koodoo?  Didn't do this with any of our phone changes in the past....

Thanks.
Photo of Paul Garthe

Paul Garthe

  • 130 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Don't worry about changing the imei online. That's only used to enter sim numbers..what's the exact model number of your Mini


Settings

..about

Edit

Just noticed you posted the model number which is the. European version.

While you'll get 3g service you won't get LTE and your best bet is turning LTE OFF.
(Edited)
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Try dialing *#2263# from the dialpad to enter ServiceMode. Tap: [1] Band Selection > [3] WCDMA > [0] WCDMA ALL. This sets the phone to scan all WCDMA Bands including; Band 5 (850 MHz) and Band 2 (1900 MHz) and prevents the phone from switching to other network modes. Bands 5 & 2 are the 3G frequencies that are compatible with Koodo's network. Do not reboot your phone. To exit ServiceMode, press the back softkey button or tap MORE > END.

GSM Only will not work - Koodo does not operate a 2G network.
Photo of Paul Garthe

Paul Garthe

  • 130 Points 100 badge 2x thumb
Thanks.

I set the mode to WCDMA only and the service provider to Koodo (only).  Still has same problem.  Sometimes it will go for hours connected, but once it looses it, it says Selected provider (Koodo) not available, and seems to stay that way, even thought it has lots of signal strength.  We do have a dual band booster since we live in a poor cell area, but the other phones beside it never loose the connection.  Put the SIM card in the Moto G3 for now, seems to work good in that phone.

*#2263# is not recognized on the phone, does not work (set it in settings menu).  Starting to think maybe the phone is defective?
Photo of Paul Garthe

Paul Garthe

  • 130 Points 100 badge 2x thumb
Thanks, havent tried the factory reset yet.  

I think maybe this phone is only operating on the un boosted signal at our house.  Without our Wilson booster, the reception is very poor.  

What bands/ frequencies doe Koodo operate on?  

If this phone has one of the 2 LTE bands matching Koodo's, will it still operate on that matching band (2100)?  Does the tower send out all bands at once?  How does the phone decide which band to operate on?

These are the phone bands:
  • 2G: GSM 850 / 900 / 1800 / 1900, 3G: 850 / 900 / 1900 / 2100, 4G: LTE 800 / 850 / 900 / 1800 / 2100 / 2600
The booster is a wilson:
The Wilson DB Pro Kit is compatible with all US and Canadian cellular providers, excluding iDEN / Nextel / MIKE. This kit supports CDMA, TDMA, GSM and AMPS cell phone technologies, as well as data protocols such as GPRS, 1xRTT, HSDPA, EVDO and EDGE. 

Frequency: 824-894 MHz / 1850-1990 MHz

Thanks
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Looks like your Booster is missing LTE Band 4

Try turning LTE OFF on your device.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
And you do the *#2263# in the dialer not the settings.
Photo of Paul Garthe

Paul Garthe

  • 130 Points 100 badge 2x thumb
When I run *#2263#, it says "USSD code running", then after a few seconds says "Connection problem or invalid MMI code".  I have tried this several times, alsways get the same error.  Even when I am connected to koodo just before and just after trying to run it.  Often it will connect to Rogers and say emergency call only.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Try

*#301279# - HSDPA/HSUPA Control Menu

Or

*#*#197328640#*#*

Look for ways to turn LTE OFF.

Edit: I am not responsible if you brick your device.
(Edited)
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Since the S5 Mini (SM-G800F) is a European variant, it’s possible that the phone could have a region lock. An unlocked phone simply means that the phone is SIM unlocked, it doesn't mean that it is region unlocked. One way to verify this is the box the phone came in would or should have had a large decal/sticker prominently displayed, stating:

European Model: This product is only compatible with a SIM-card issued from a mobile operator within Europe. (as defined EU/EEA, Switzerland and the following Non-EEA countries Albania, Andorra, Bosnia and Herzegovina, Former Yugoslav Republic of Macedonia (F.Y.R.O.M), Monaco, Montenegro, San Marino, Serbia and Vatican City.)

To use SIM cards from other regions, a cumulative call over five minutes must first be made with the SIM card from a European operator. Another option is to email Samsung Support and ask them to provide you with the region unlock code. The region lock is a protection mechanism aimed at gray market re-sellers who might try to offer Unlocked EU units in places where they weren't meant to go.

http://www.samsung.com/global/support...

This might explain why the phone keeps getting disconnected from Koodo's network, despite having good signal strength.

Side note: *#2263# will not work on devices running Android 5.0 (Lollipop) and works on devices running Android 6.0 (Marshmallow). *#*#4636#*#* should work on devices running Android 5.0. Select Phone Information - scroll down to and tap Set Preferred Network Type - select WCDMA Only. Not sure if this will remedy the problem, but it's here for future reference if anyone needs it.
Photo of Paul Garthe

Paul Garthe

  • 130 Points 100 badge 2x thumb
Thanks. I'm going to try to get product support from the vendor of the phone . None of the above codes work to turn off LTE. The *#*4636#*#* and *#*#197328640#*#* both give "the number you have reached is not in service". The *#301279# gives the same invalid code error as *#2263*. I did set the phone on WCDMA only in the network settings. Android version is 5.1.1. Using LTE Discovery and SingalCheck Lite was usefull. Found out it gets same signal as my (AT&T unlocked) S5, but the S5 stays connected to Koodo, while the S5 mini hops to Rogers ("Edge" instead of UMTS), and seems to stay stuck there for Emergency calls only", unless it gets a strong Koodo signal. Close to the cell booster, the S5 mini finds and stays connected to Koodo reliably.
Photo of rikkster

rikkster, Mobile Master

  • 66,906 Points 50k badge 2x thumb
Actually, the codes do work. I've tried them on my S7 Edge, S5 Neo and Moto Play. I think the codes are region-specific. If you're getting a reliable connection when the S5 Mini is close to the booster, then perhaps the gain control on the booster might need to be adjusted to allow more signal to propagate throughout your home. Keep us posted, I'd be interested in hearing what vendor support has to say.
Photo of Paul Garthe

Paul Garthe

  • 130 Points 100 badge 2x thumb
Instructions from Samsung are put in safe mode for a few hours, if that does not work, do factory reset, if still NG, then send to authorized dealer for service.  Did safe mode, no difference, Just did factory reset, also seems to make no difference, but will try it for a few days.  Going to try to point outside antenna on booster at cell tower.
Photo of rikkster

rikkster, Mobile Master

  • 66,906 Points 50k badge 2x thumb
From what you mentioned earlier, the S5 Mini maintains a reliable connection, sometimes for hours, when placed near the booster. It's possible the S5 Mini may have weaker signal reception compared to your other phones. Not all cell phones are created equal.

It might be a good idea to contact weBoost (formerly Wilson Electronics) directly to see if they can offer some advice or a solution.

https://www.weboost.ca/about-us/#cont...
(Edited)
Photo of Paul Garthe

Paul Garthe

  • 130 Points 100 badge 2x thumb
After using it a few more days, concluded that it is most likely a defective phone.  Connects to Rogers way too often and for too long.  Even when showing Koodo connection it will often drop calls or decide it has no service on calls.  Amazon vendor wanted us to send it Fedex Prepaid to Germany for Warrenty, since we missed return period for them to take it back by a few days.  Samsung would not service it in Canada, said it would need to be serviced in Europe (has 2 year warrenty), or have it serviced at our cost in Canada.  

It was an amazon fulfillment order, so Amazon agreed to take it back (because we are a good customer to quote their words).  This time going to try an AT&T phone, and install a directional antenna on the booster.  My Amazon/ S5 AT&T phone works great on Koodo (as does the Amazon Moto G3 international dual sim version).

Thanks for all your help!