Keep getting "no SIM card installed" or no service after carrier update

  • 1
  • Question
  • Updated 1 month ago
  • Answered
I did carrier update on my phone yesterday and since then I keep getting "no SIM card installed" or no service notices. rebooting fixes the problem, but then it happens again a little while later. Live in Newmarket. Have an iPhone6 with iOS 10.3.2 on a monthly plan.
Photo of Kathy Waterworth

Kathy Waterworth

  • 90 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 96,868 Points 50k badge 2x thumb
Try taking the Sim card out and put it back in again and then restart it. It seems unlikely given it started when you got the update but it might need a new Sim if it keeps up. Generally how long does it take before it happens again after a restart?
Photo of Kathy Waterworth

Kathy Waterworth

  • 90 Points 75 badge 2x thumb
I just tried taking out the SIM card.  Working at the moment. Will see if it holds. As it's been a quiet day, I haven't been timing it exactly, but every few hours the service is gone again. 
Photo of Goran

Goran, Mobile Master

  • 96,868 Points 50k badge 2x thumb
Alright let us know if it happens again.
Photo of Kathy Waterworth

Kathy Waterworth

  • 90 Points 75 badge 2x thumb
Here we are , a year later, and it’s started happening again. It’s happened at least 8-10 times over the last few days. Have had to reboot each time to get it to work again.
Photo of Goran

Goran, Mobile Master

  • 96,868 Points 50k badge 2x thumb
You might need to get a new sim card. See if you can use another phone for a day or two to see if the problem follows.