Is my new Unlocked Verizon Samsung s6 compatible with koodo?

  • 1
  • Question
  • Updated 11 months ago
  • Answered
I bought a factory unlocked Verizon Samsung s6 and fear I've made a mistake. Can't seem to call or text with my koodo prepaid sim card. Have I bought something I won't be able to use with Koodo? 
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb

Posted 12 months ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 195,954 Points 100k badge 2x thumb
Yes the phone is compatible with Koodo.

Are you getting any bars when you insert the sim?
Try your sim in your previous phone.  Does it work?
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
Cant try my sim on last phone as it's a different size.  But registration was no problem with koodo with this prepaid sim.
Photo of Sophia

Sophia, Mobile Master

  • 142,984 Points 100k badge 2x thumb
Does it show that it is connected to the Koodo network?
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
Where to look for this?
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
I did all the apn settings for Koodo but feel like there is something I'm missing...
Photo of Robert

Robert, Mobile Master

  • 106,744 Points 100k badge 2x thumb
Do you have any credit left on the prepaid card? Maybe that's the reason why I won't work.
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
Yes.   Fully loaded.
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
The prepaid is all new and fully loaded.  The phone uses nano sim, which my old phone does not, but I was able to register successfully. Through this forum, I learned about APN which I have updated to Koodo settings (it only listed verizon before).  I feel like there is still something I'm missing in order to phone and text...
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
OK, global seems to be the default.
If I try to call it says Mobile Network Not Available
Photo of Dennis

Dennis, Mobile Master

  • 186,578 Points 100k badge 2x thumb
Try the UMTS one
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
No good.  Keeps bumping me back to Global.
Photo of Dennis

Dennis, Mobile Master

  • 186,578 Points 100k badge 2x thumb
When global is selected, can you go to Network operators and manually select Koodo (warning this will take a few minutes to scan and detect the networks)
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
Network Operators remains greyed.  Not accessible.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,130 Points 100k badge 2x thumb
When you go into settings - About phone - status does it show your number
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
I'm certain it is unlocked, but when I try to make a call I get a message saying Mobile Network Not Available.  Since the Sim doesn't fit into my old phone, I'm not sure how to test it exactly.
Photo of BobTheElectrician

BobTheElectrician

  • 67,100 Points 50k badge 2x thumb
The compatibiity data listed in the eBay ad is the usual confusathon. In the body of the ad, 3G is listed as CDMA, and the appropriate bands are 2G only, neither of which are supported by Koodo out of the box. 

(Edited)
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
Ah, that's just plain crappy.
I'll be trying for a refund but will likely have to find a way to sell it in the US?  Blah.  Any suggestions?
Photo of Dennis

Dennis, Mobile Master

  • 195,954 Points 100k badge 2x thumb
At this point we are unsure if this is a phone issue or a sim card issue.  I suggest testing your sim card on another unlocked or Koodo/Telus phone (friends or family) to see if the sim card works.  Or try another sim card (from friends or family) in your S6 and see if it works
Photo of Robert

Robert, Mobile Master

  • 106,744 Points 100k badge 2x thumb
Before selling it, I'd at least verify if it's the card that is causing the problem.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,130 Points 100k badge 2x thumb
Try switching the setting you can't switch this way
If enabled you can also go #*#*4636*#*# and go to phone information and switch the settings to LTE/WCDMA
Photo of BobTheElectrician

BobTheElectrician

  • 67,100 Points 50k badge 2x thumb
You have to be careful with Verizon gear, because even though the carrier has a legacy of supporting CDMA, 2G, 3G and LTE on many frequencies, the handsets don't necessarily cover them all. They also have a reputation along with Tracfone of having the most locked-in system.

Regardless of what the general phone specs are, it's likely that the eBay ad is accurate and that the 3G frequencies you need with Koodo may not be activated in firmware on that particular sub-model.
Photo of BobTheElectrician

BobTheElectrician

  • 67,100 Points 50k badge 2x thumb
There is a trend now with some vendors to tailor a price point by limiting features or adding unwanted ads. Take a look on Amazon and you will see phones that are $50 cheaper because the home screen is an advertising billboard.
Photo of Ben Cuthbert

Ben Cuthbert

  • 80 Points 75 badge 2x thumb
Hey Bob, you seem to know what you're talking about.. I'm in a very similar boat- bought a Samsung S6 G920V from ebay. My phone will send texts and make calls, but I can't get the data working. I can select the "LTE / GSM / UMTS" option, but I only see TELUS, Rogers, and Bell in the Network Operators list. Connecting to TELUS doesn't seem to let me use data. 

You've suggested that the issue is firmware- is it possible that rooting my phone could help?
Photo of Allan

Allan, Mobile Master

  • 61,960 Points 50k badge 2x thumb
Have you set Koodo's APN settings up in your phone?
https://www.koodomobile.com/help/sett...
Photo of Ben Cuthbert

Ben Cuthbert

  • 80 Points 75 badge 2x thumb
I hadn't, thanks. I just added the APN, but nothing seems to have changed. I still don't see Koodo under the network operators
Photo of rikkster

rikkster, Mobile Master

  • 68,252 Points 50k badge 2x thumb
Are you able to delete/discard the Verizon APN? If you're able to delete the Verizon APN, try resetting the phones' network settings by going to: Settings > Backup and reset. From the Reset section, tap Reset network settings. Review the info then tap RESET SETTINGS > tap RESET SETTINGS to confirm

https://willmyphonework.net/ says your device should work with Koodo. Device specs on Samsung's website indicate that the SM-G920V has the HSPA/UMTS frequencies (3G & 4G) and Band 4 for LTE which again, should be compatible with Koodo's network. This is a weird one and I'm leaning toward Bob's explanation, should all else fail. 

http://www.samsung.com/us/support/owners/product/galaxy-s6-verizon (Specifications)

Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
Thanks!  I will try all this now.
Photo of Corynn Gammon

Corynn Gammon

  • 154 Points 100 badge 2x thumb
OK, I was unable to delete the Verizon APN as it is greyed out.  I did the Reset Settings.
I, like Bob, think I've been "had".  Sadly out $300 CDN which could lead to a divorce here! lol
I have contacted the seller and his replies have not been helpful.  I will likely (after I double check the sim card, of course) let ebay know what happened and then attempt to sell it in the US.
Photo of Dennis

Dennis, Mobile Master

  • 195,954 Points 100k badge 2x thumb
Make sure to file a claim with PayPal especially if they misled you in their sales page in anyway. EBay and PayPal heavily favour the buyer and protect them first over the seller
Photo of Ben Cuthbert

Ben Cuthbert

  • 80 Points 75 badge 2x thumb
Repeated from elsewhere: I'm in a very similar boat- bought a Samsung S6 G920V from ebay. My phone will send texts and make calls, but I can't get the data working. I can select the "LTE / GSM / UMTS" option, but I only see TELUS, Rogers, and Bell in the Network Operators list. Connecting to TELUS doesn't seem to let me use data. 

You've suggested that the issue is firmware- is it possible that rooting my phone could help?
Photo of rikkster

rikkster, Mobile Master

  • 68,252 Points 50k badge 2x thumb
Last ditch attempt. Dial *#2263# from your phones' dialpad. If the code works, the phone should display the ServiceMode menu. Under Network Setting, tap [1] Band Selection > tap [3] WCDMA > choose [0] WCDMA ALL. Tap the three dots in the upper right corner of the screen (Menu) and select Back to go backward through the menu pages. The phones' back key serves the same purpose, but you'll have to redial the code.

What this 'should' do is prevent the phone from jumping to global mode and locks the phone to a specific set of frequency bands. There's no need to reboot, the phone will switch to the WCDMA protocol automatically.

Back to the main ServiceMode window, under Network Setting, tap [3] HSPA Setting. The HSPA Setting should be set to selection [6] HSPA_REL9 [*]. an asterisk indicates that this setting has been selected. 

 

                                                             

Once you've completed those steps, try resetting the phones' network settings with the instructions I provided earlier. Also, try to manually associate the phone with Koodo's network, I believe Dennis mentioned this earlier. The images are from my Galaxy S7.

It's a Verizon phone, so the steps above may or may not work. Figured I'd give this a shot before you sell the phone.