Is it the network or is it my phone?

  • 1
  • Question
  • Updated 9 months ago
  • Answered
Is it the network or is it my phone? Lately, I have been getting frequent "message not delivered" or "call failed" in response to messages or calls. Also, lately my iPhone 4S shows "No Service" when I am at home but connects when well away from the house; previously it connected just fine at home.
Photo of EMHopkins

EMHopkins

  • 110 Points 100 badge 2x thumb

Posted 10 months ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 107,634 Points 100k badge 2x thumb
Hello Em,

I think it's your phone. I haven't had any issues lately? Have you tried restarting your phone, maybe that would solve the problem?
Photo of EMHopkins

EMHopkins

  • 110 Points 100 badge 2x thumb
Yes thanks, I tried. Restarting did not make a difference.
(Edited)
Photo of David

David, Mobile Master

  • 93,940 Points 50k badge 2x thumb
It is possible the tower you connect to while at home has changed somehow, affecting your service when at home. Has rebooting as Robert suggested made a change?
Photo of EMHopkins

EMHopkins

  • 110 Points 100 badge 2x thumb
Thanks but no, rebooting did not help.
(Edited)
Photo of Dennis

Dennis, Mobile Master

  • 196,890 Points 100k badge 2x thumb
Settings>Reset>Reset Network Settings may help as well.  Not that wifi passwords will be lost
Photo of EMHopkins

EMHopkins

  • 110 Points 100 badge 2x thumb
Thanks, I did try resetting network setting to no improvement.
(Edited)
Photo of Dennis

Dennis, Mobile Master

  • 196,890 Points 100k badge 2x thumb
If you are getting great signal outside but poor/no signal at your house then it could be a tower change.  Unfortunately there is nothing that can be done about this.  Do the other carriers operate well in your home?
Photo of EMHopkins

EMHopkins

  • 110 Points 100 badge 2x thumb
Two other family members have the same service as I do and have no trouble with getting a signal when at home. They show complete connection when I show "no service" or a weak signal.
Photo of David

David, Mobile Master

  • 93,940 Points 50k badge 2x thumb
Then that would suggest a phone issue, not a service issue, wouldn’t it?