iPhone 5S displays "No Service"... what can I do??

  • 2
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: *611 or 1-866-995-6636 mentions

I bought an iPhone 5S about a month ago, and I believe that it is locked to Telus. Since Koodo is a branch of Telus, I have read that the Koodo sim cards will work on Telus phones. The phone has been working perfectly fine with my service provider, but since this morning I have had no service at all. I reset my phone, turned it off, disabled LTE, enabled LTE, etc. Still not working. Help!
Photo of Big R

Big R

  • 110 Points 100 badge 2x thumb
  • frustrated

Posted 4 years ago

  • 2
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
It's not 100% that it'll worked when locked to Telus. You may want to look into getting it unlocked.
Photo of Big R

Big R

  • 110 Points 100 badge 2x thumb
Alright, I can understand that. I'm thinking of getting it unlocked, but how come it worked with the Telus phone for a good 3 weeks no problem??
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
An unlock may not be necessary. Try turning airplane mode on/off.
Photo of Big R

Big R

  • 110 Points 100 badge 2x thumb
Nope... didn't work.
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
Give Koodo a call then, *611 Option 6.
Photo of Lise Rousson

Lise Rousson

  • 64 Points
Write a comment...
hi Myke, how bout my iphone 4 here's in the Philippine, gave my sister, but locked in koodo. Is there any contact? Thanks IME(012651007644749
)
Photo of Dave

Dave

  • 7,814 Points 5k badge 2x thumb
Is there a spot on their to enable 3G or to make sure that it is in auto mode - I have found that 3G has to be enabled as Koodo does not have anything below 3G (auto mode is the same thing as enabling 3G)
Photo of Big R

Big R

  • 110 Points 100 badge 2x thumb
3G is enabled... I'm going to talk to Koodo today.

This conversation is no longer open for comments or replies.