iPhone 5 LTE not working

  • 2
  • Question
  • Updated 4 years ago
  • Answered
I got my wife a nano SIM Card from Koodo for her unlocked iPhone 5. However, she never get the LTE signal on her phone. Below are more information regarding the phone:

- Phone was purchased unlocked from Apple Canada.
- My home has LTE coverage. I tried replacing her SIM Card with another friend Koodo Prepaid SIM Card (Purchased around 1 year after Nano SIM Card first available) and the phone got LTE signal.
- LTE is enabled and I did try the network reset and all other test mentioned in this forum.
- Nano SIM Card was purchased when iPhone 5 first came out (first time Nano SIM Card was available).

My question is whether there is a known issue with the first batch of the Nano SIM Card where it is not able to connect to LTE network? Thank you.
Photo of RS

RS

  • 230 Points 100 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Jorden

Jorden, Mobile Master

  • 33,404 Points 20k badge 2x thumb
I went through the exact same process (bought an iphone 5 unlocked from Apple on launch day), my day 1 nano sim has had no problem with LTE. Sounds like it could be an issue with your sim, especially if LTE is working with a different sim.
Photo of RS

RS

  • 230 Points 100 badge 2x thumb
Any idea what are my options then, if that is the case?
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
You probably need another SIM card, $20 for prepaid, including $20 service credit.

I personally wouldn't bother with it as I still fail to see any noticeable benefit when using LTE and it really affects battery life.

This conversation is no longer open for comments or replies.