iPhone Visual Voicemail problems

  • 1
  • Question
  • Updated 1 year ago
  • Answered
I added the visual voicemail on the self serve site about a week ago and it doesn't seem to work on my iPhone 6 (When I go to the voicemail tab on my phone, it just dials into the voicemail box.)  I have downloaded the new carrier settings and have tried just about everything I can find to try and get it working.  Does anyone have any suggestions on how to get it working?
Photo of MB

MB

  • 140 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 103,744 Points 100k badge 2x thumb
Hello MB.

I'm not sure if it's relevant but maybe it's related to data? Do you have a data plan?

Have you tried powering on and off your phone?
Photo of MB

MB

  • 140 Points 100 badge 2x thumb
I do have a data plan.  I have also powered it on and off several times.
Photo of Dennis

Dennis, Mobile Master

  • 187,544 Points 100k badge 2x thumb
Does your data plan work when away from wifi?
It also takes about 24 hours for Visual voicemail to activate.  Did you add this add-on on self serve?
Photo of MB

MB

  • 140 Points 100 badge 2x thumb
Yes, the data plan works over wifi.  I also added this to my plan over a week ago and it hasn't worked.  Would it possibly work if I removed it from my plan and re-added it?  Or will that cause issues with my bill?
Photo of Dennis

Dennis, Mobile Master

  • 187,544 Points 100k badge 2x thumb
I mean not over wifi.  Like turn off wifi and try your data
Photo of MB

MB

  • 140 Points 100 badge 2x thumb
Sorry, I misread that! Yup, it does work when I'm away from wifi.
Photo of Daniel

Daniel, Employee

  • 5,712 Points 5k badge 2x thumb
Hi MB! Did you use these instructions from Apple to update your carrier settings: http://koo.do/1H8Pv0n and do you have the latest software version on your phone? Keep us posted. 
Photo of MB

MB

  • 140 Points 100 badge 2x thumb
Yes, I did that before.  There was an update, and I pressed ok, but it's still not working.
Photo of Julie

Julie, Company Admin

  • 2,344 Points 2k badge 2x thumb
Hey MB! We see that you removed/added the add-on through self-serve, did that help? 
Photo of MB

MB

  • 140 Points 100 badge 2x thumb
It did!  It's working now.  Thanks for following up!
Photo of Julie

Julie, Company Admin

  • 2,344 Points 2k badge 2x thumb
Awesome!! I'm glad to hear that :). Have a great weekend!
Photo of Sanam Bawa

Sanam Bawa

  • 60 Points
hi, 

i've tried the above steps and followed the link posted above. I'm having the same issue where I have to dial into my voicemail to even see how many I have etc. 

visual voicemail is not working. 

any suggestions?