iPhone SE won't receive texts from Samsung users.

  • 1
  • Question
  • Updated 1 year ago
  • Answered
So I've deduced that all people unable to send me texts are Samsung users.  They are able to send my husband texts (same type of phone, activated on the same day, sharing an account,) but not me.  I spoke with a Koodo rep, and reset my network settings, but to no avail.  I am able to text and call them, but they are unable to text me (they can call.)  All users receive a message saying xxx-xxx-xxxx is invalid or does not subscribe.
What gives?  I can't very well ask everyone I meet what kind of phone they have and go through some rigmarole to get my info to work.
Photo of Lauren Austen

Lauren Austen

  • 130 Points 100 badge 2x thumb
  • frustrated!

Posted 1 year ago

  • 1
Photo of rikkster

rikkster, Mobile Master

  • 66,412 Points 50k badge 2x thumb
Hi Lauren,

Are you using iMessage? Samsung phones use SMS messaging. In order to receive an SMS message, iMessage needs to be turned off. To switch to SMS, go to Settings > Messages and turn off iMessage. Your iPhone will now send/receive all messages in SMS text message format instead of using the iMessage service.

Photo of David

David, Mobile Master

  • 83,518 Points 50k badge 2x thumb
Messages (formerly called iMessage) does not need to be turned off to receive (or send for that matter) SMS from users. Lauren needs to look elsewhere to find the solution. I will guess that messages from iPhone users are arriving to her phone through Messages, while SMS are not. It would be interesting to learn if other Android phones can send SMS, or is it ONLY Samsung phones. It would also be good to know if the carrier makes a difference. If a Samsung user on Koodo can't send SMS, it becomes really interesting.

More sleuthing needed to get to the bottom of this one, I'm afraid.  I expect a reset may be needed at the Koodo end of things.