iPhone not sending or receiving text messages for only one contact

  • 1
  • Question
  • Updated 8 months ago
I just got a new prepaid account and using an iPhone 5s. I have had no problems texting except for one number. The number is correct, and I’ve received some texts from them, but not all. And none of my texts have failed to send to that number. Any ideas why?
Photo of Brenna

Brenna

  • 128 Points 100 badge 2x thumb
  • confused

Posted 8 months ago

  • 1
Photo of Allan

Allan, Mobile Master

  • 62,352 Points 50k badge 2x thumb
Has that person been having any trouble with other people texting them or only you?
Photo of Brenna

Brenna

  • 128 Points 100 badge 2x thumb
Only me. She has an iPhone too (all other numbers I’ve texted without issue so far have been android).
Photo of Erwin

Erwin

  • 23,576 Points 20k badge 2x thumb

Hi Brenna,

Can you go to settings, find "messages," and turn off "iMessage." This will allow you to send and receive text messages from anyone regardless of a wifi connection.

Photo of Brenna

Brenna

  • 128 Points 100 badge 2x thumb
Thanks! Ok I can now send her messages but I’m not getting any of hers right now.
Photo of Dinh

Dinh, Mobile Master

  • 36,114 Points 20k badge 2x thumb
Because you turned off iMessages, other person iPhone still thought you had iMessage on, and sent imessage instead of SMS. You would need to wait a bit (it can be automatically resolved), or ask your friend to send you sms instead of imessage by turning on the option (general --> message --> send as sms "ON")
(Edited)
Photo of Brenna

Brenna

  • 128 Points 100 badge 2x thumb
Thanks! They turned off their iMessage and it works now, but they don’t want to have it permanently turned off... so I guess I hope it fixes itself.
(Edited)
Photo of Erwin

Erwin

  • 23,576 Points 20k badge 2x thumb
I get you Brenna, iMessage has some cool features regular SMS does not have. You can have iMessage turned on and have it automatically switch to SMS if it cannot send a message because of unresponsive Wifi connection or if data is turned off. Go ahead and turn on iMessage again, wait a few seconds until more options show up below, the turn on “send as SMS”

Unfortunately, Apple does not have this feature pre-selected.
(Edited)