iPhone cannot access mobile network even though it shows LTE, on returning from overseas where I used another SIM card

  • 1
  • Question
  • Updated 1 month ago
my iPhone shows it is connected to LTE but whenever going online, the pop up windows says "Could not activate mobile data network: turn on mobile data or use Wi-Fi to access data".  I have tried turning the phone off and on, removing and reinserting the SIM card, LTE/Roaming off and on, manually selecting Koodo services.  My iOS is up to date. This has happened since I have used a different SIM while away from Canada.
Photo of Joe

Joe

  • 90 Points 75 badge 2x thumb

Posted 1 month ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 91,406 Points 50k badge 2x thumb
So you still show as connected to Koodo until you go online? Did you try resetting network settings and redoing your APN settings?
Photo of Joe

Joe

  • 90 Points 75 badge 2x thumb
Thanks. It now works. I had to remove two other APN settings and install Koodo's using unlockit.co.nz.

Is it possible to switch profiles?  It seems quite laborious that each time we switch SIMs we have to be on Wifi to reset the APN.
Photo of Dennis

Dennis, Mobile Master

  • 186,454 Points 100k badge 2x thumb
Are you bit able to edit your APN settings normally without unlockit? I thought koodo allowed that with a carrier setting update a couple years ago
Photo of Goran

Goran, Mobile Master

  • 91,406 Points 50k badge 2x thumb
Glad to hear it works now!

You can usually have multiple APNs saved but I haven't had to do that on an iPhone ever so I'm not too familiar with storing APNs in iOS settings.
Photo of Joe

Joe

  • 90 Points 75 badge 2x thumb
It is possible that when I installed the other carrier's profile, I accidentally removed Koodo's. I thought Koodo's APN was just sp.koodo.com and I saw that (on returning to Canada). But until I used unlockit, I wasn't able to use mobile data (notwithstanding the "LTE" indicator and the sp.koodo.com APN).  It is possible that somehow the other profile(s) interfered with Koodo's.