Iphone 6 with no data but mms services

  • 2
  • Question
  • Updated 3 years ago
  • Answered
I have an iPhone 6 with a plan that doesn't include data but includes MMS services. I have an android before so i was easily able to configure the APN to mms only but on the iPhone it is not so easy. What do I do to block data but not my mms messaging?
Photo of Andrew

Andrew

  • 90 Points 75 badge 2x thumb

Posted 3 years ago

  • 2
Photo of Dennis

Dennis, Mobile Master

  • 187,078 Points 100k badge 2x thumb
It's even easier for the new iphones

http://community.koodomobile.com/kood...
Photo of Andrew

Andrew

  • 90 Points 75 badge 2x thumb
Thank you for the reply, I just tried this and tried sending a picture message but it did not work it keeps saying try again
Photo of Andrew

Andrew

  • 90 Points 75 badge 2x thumb
Never mind it worked! Just had to restart my phone!
Photo of Dennis

Dennis, Mobile Master

  • 187,078 Points 100k badge 2x thumb
Sweet!
Photo of Dennis

Dennis, Mobile Master

  • 187,078 Points 100k badge 2x thumb
I just tested it and it works for me. Make sure you are not trying to send an imessage.

Also make sure your MMS APN is not changed at all
Photo of Aryka

Aryka

  • 176 Points 100 badge 2x thumb
How do I send an MMS that isn't an iMessage? I modified the APN settings as described in that link, and restarted the phone. iMessage is turned off right now, and MMS is enabled.
Photo of Dennis

Dennis, Mobile Master

  • 184,920 Points 100k badge 2x thumb
Did you leave the APN settings under MMS as the default?

And what happens when you try to send an MMS?
Photo of Aryka

Aryka

  • 176 Points 100 badge 2x thumb
Yes, and it just doesn't send.

I found this helped:
https://apn-canada.gishan.net/setting...

I changed the APN settings for everything else to prevent those types of data going through. I turned on data and, as mentioned, disabled iMessage and enabled MMS, and it seems to be working now.
Photo of Dennis

Dennis, Mobile Master

  • 184,920 Points 100k badge 2x thumb
Sweet. As long as you got it to work

This conversation is no longer open for comments or replies.