International texts not delivered

  • 1
  • Question
  • Updated 1 year ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: No longer valid due to Easy Roam

I am currently in France, and before I left Canada, I added the txt15 to my plan (I'm on an iPhone 5C). I have been in a couple different countries, and have had issues with receiving texts. When I was in Iceland, I was able to receive texts, and eventually, was able to send them (after switching to a different network). When I went to the UK, I was still able to receive texts, but no matter which network I was on, I wasn't able to send anything out. I was only there for 2 days, so I wasn't too concerned. Now, I'm going to be in France and Spain for the next 1.5 weeks, and I still can't figure it out. In France, I've been able to receive a message, but anything I try to send won't go through and I get a "not delivered" message back. I've tried joining all the different networks available, and I still haven't figured it out. 
Photo of Rachel Meagan

Rachel Meagan

  • 120 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Allan

Allan, Mobile Master

  • 62,040 Points 50k badge 2x thumb
That add-on only comes with 75 outgoing texts total over 30 days. Have you made 75 texts already?

If so you have the option of adding the other international roaming add on or adding the international pay per use add on to access the pay per use rates.
(Edited)
Photo of Rachel Meagan

Rachel Meagan

  • 120 Points 100 badge 2x thumb
Hey Allan! I have only used about 5 of them. I'm saying that assuming that all of the undelivered messages don't count against my usage. That being said, it still shouldn't be over 75 texts already. Any other suggestions?
Photo of Allan

Allan, Mobile Master

  • 62,040 Points 50k badge 2x thumb
Have you tried turning off iMessage, and deleting all your past conversations with the person you are trying to text? Also make sure you are texting the number and not a possible iMessage account.
Photo of Rachel Meagan

Rachel Meagan

  • 120 Points 100 badge 2x thumb
Hey Allan,

Thanks for replying! My iMessage has been turned off, and the person I'm trying to message isn't on an iPhone. I'm travelling, and trying to message my tour director, so there was no conversation previous to me leaving Canada. Thoughts?
Photo of Dennis

Dennis, Mobile Master

  • 196,006 Points 100k badge 2x thumb
Have you tried rebooting your phone?
If this does not work, you may need to contact koodo.  Your best bet is to send them a private message on facebook or twitter and they can look deeper into it.
Photo of Rachel Meagan

Rachel Meagan

  • 120 Points 100 badge 2x thumb
Thanks Dennis, I have tried rebooting my phone 3 or 4 times now, so that hasn't helped yet. I've rebooted it with each of the different networks hooked up, just in case that helps. :(
Photo of Bernard

Bernard, Official Rep

  • 80,726 Points 50k badge 2x thumb
Everything looks fine from our end Rachel. Meaning that your account is properly set up to be able to text internationally. The one question that wasn't asked yet is where you are trying to text and what prefix numbers are you using. Like country code and city code. If those are not properly put in text won't go through. 
Photo of Rachel Meagan

Rachel Meagan

  • 120 Points 100 badge 2x thumb
Hey Bernard,

The number that I'm trying to text is a UK number (+44 followed by a 10 digit number), but I've also tried to text back to Canada. I've tried with and without using the +1 code in front of the 10 digit Canadian number. Is how how I should be doing it?

Thanks!

Rachel
Photo of Dennis

Dennis, Mobile Master

  • 196,006 Points 100k badge 2x thumb
Photo of Mary Meiklejohn

Mary Meiklejohn

  • 130 Points 100 badge 2x thumb
I'm not sure if you have resolved this but I'm in Spain right now and my family has 3 iPhones 2 work and 1 is having the exact problems you describe and I have tried everything that has been suggested too.   Nothing has worked.

It's the newer SE iPhone that isn't working
Mary
Photo of Ranjan

Ranjan, Official Rep

  • 30,118 Points 20k badge 2x thumb
Hi Mary - is this for the phone number starting with 929? If so, I just added the $0 pay-per-use international long distance feature to your account, which should help resolve the issue. Try rebooting your phone and trying again. Let us know if that helps. 
Photo of Mary Meiklejohn

Mary Meiklejohn

  • 130 Points 100 badge 2x thumb
Thank you for you quick response!!

It's working great now.

Mary
Photo of Rachel Meagan

Rachel Meagan

  • 120 Points 100 badge 2x thumb
Hey everyone! Just wanted to say that I ended up getting this resolved. The Koodo rep added the "international data feature" and now I have no trouble using it! Thanks for all the advice! :)

This conversation is no longer open for comments or replies.