International roaming not working...can't call or text in France

  • 2
  • Question
  • Updated 7 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: No longer valid due to Easy Roam

I purchased the ALL40 plan for international roaming on Oct 3 for my iphone SE and the TEXT15 plan for my husband's Samsung Galaxy. We arrived in Paris on Oct 5th and as soon as we turned on our phones in the airport we received the 'Welcome to France...' Text message from koodo. However, we are unable to make calls, text each other or our host here in Paris. Our phones indicate they are on the local networks ( selected Orange, Free, and Bouygues.... Looks on the screen as though we have service but cannot make any calls or texts). Tried all the usual ideas (turning phones off/ on again, logging off network and back on...) emailed koodo on the 6th and have not heard back yet. Looking for help.... TIA
Photo of jm

jm

  • 122 Points 100 badge 2x thumb
  • frustrated

Posted 7 months ago

  • 2
Photo of Robert

Robert, Mobile Master

  • 103,372 Points 100k badge 2x thumb
Hello there,

While travelling outside the US, there are 2 reasons why you might not get service.

Have you added the free international roaming package from self serve? Is data roaming enabled on your phone? If you are not in the USA, you require the free International voice add-on be active on your account to connect to other carriers. If you didn't add them prior to your departure, add them (click here to know how) and then turn airplane mode on for 30 seconds and off.

Wish you a wonderful vacation!
(Edited)
Photo of jm

jm

  • 122 Points 100 badge 2x thumb
Thanks for your thorough reply.  I am right in Paris and have tried to access service in different part of the city, so I cannot imagine that this issue is related to there not being coverage. As to your second point - I did not add the free international roaming package... only the ALL40 plan. I’ve looked through the koodo self-serve site but cannot locate this option, and unfortunately your link did not work for me.  Could you direct me where to go to sign up for this?Thanks again
Photo of Allan

Allan, Mobile Master

  • 56,506 Points 50k badge 2x thumb
Login, click view rate plan, click manage add one, then add International Voice Roaming, International Data Roaming and Pay Per Use Intl Long Distance.
Photo of jm

jm

  • 122 Points 100 badge 2x thumb
Thanks. Int’l Voice Roaming is added but there is no option for Pay per use Intl Long Distance. Also, am I correct in thinking that I do not have to have data roaming turned on in order to send a text message (not an iMessage) or make a call here in Paris?
Photo of Allan

Allan, Mobile Master

  • 56,506 Points 50k badge 2x thumb
Correct, the data roaming is just to use data. The ALL40 plan includes 50MB of data to use.
It's strange that you aren't seeing the pay per use add-on. I'd suggest sending a message to Koodo via Facebook and ask them to add it for you.
Photo of jm

jm

  • 122 Points 100 badge 2x thumb
Thanks for your thorough reply.  I am right in Paris and have tried to access service in different part of the city, so I cannot imagine that this issue is related to there not being coverage. As to your second point - I did not add the free international roaming package... only the ALL40 plan. I’ve looked through the koodo self-serve site but cannot locate this option, and unfortunately your link did not work for me.  Could you direct me where to go to sign up for this?Thanks again
Photo of Goran

Goran, Mobile Master

  • 90,274 Points 50k badge 2x thumb
It is in add-ons. You will see it called international voice roaming and international data roaming for data. If you need more than the bare minimum of calling and data then I suggest you get a prepaid sim with Free Mobile. It's 20 Euros for 100GB of data.
Photo of jm

jm

  • 122 Points 100 badge 2x thumb
Ok, it looks as though the International Voice Roaming is added, as well as the International Data.  There is no option for Int’l Pay Per Use. 
Photo of Goran

Goran, Mobile Master

  • 90,274 Points 50k badge 2x thumb
Hmm. Take out your Sim card, put it back in, restart your phone. Then toggle airplane mode again. See if that helps now.
Photo of Bernard

Bernard, Official Rep

  • 75,526 Points 50k badge 2x thumb
@Jm, can you pls try to put your phones on airplane mode and back? Let us know if that help reset things. 

This conversation is no longer open for comments or replies.