International roaming no network access

  • 1
  • Question
  • Updated 7 months ago
I added international roaming. Curacao is on the list of countries, but I can't get onto the digicel network here. Ideas please!
Photo of Rosanne

Rosanne

  • 80 Points 75 badge 2x thumb

Posted 7 months ago

  • 1
Photo of Dinh

Dinh, Mobile Master

  • 42,336 Points 20k badge 2x thumb
I would let the Carrier selection to Automatic and see if it can pick one while roaming.

Which phone are you using? Make sure your phone is compatible with Digicel network. They might use different bands from Koodo/Telus.
(Edited)
Photo of Goran

Goran, Mobile Master

  • 97,798 Points 50k badge 2x thumb
From what I can tell, Curacao primarily uses 1800mhz. That might be why. Rather go into manual network selection mode and see if it pops up and you can connect. It's quite possible that your phone doesn't have that band. Which phone do you have? Try willmyphonework.net to see if it'll work in Curacao. It's not 100% accurate but it's pretty good.
Photo of Rosanne

Rosanne

  • 80 Points 75 badge 2x thumb
Thank you both. My phone is a Samsung Galaxy core LTE. Auto select doesn't work, it spins for awhile and then tells me to "try again later".. Tried the website, looks like the local carrier only supports 2G or 3G. I set my network mode to GSM, still doesn't connect. I get a message that says my SIM card is not compatible. Was I to purchase a local sim card even though I added roaming to my account?
Photo of Goran

Goran, Mobile Master

  • 97,798 Points 50k badge 2x thumb
May as well get a local sim butif your phone won't connect as it is not sure if that'll help in the end. You could always ask to try a sim or if it's super cheap just throw a couple bucks at it and give it a go.
Photo of Dinh

Dinh, Mobile Master

  • 42,336 Points 20k badge 2x thumb
From this website: http://prepaid-data-sim-card.wikia.com/wiki/Cura%C3%A7ao  it seems they use 900/1800 2G for talk. So theoretically, your phone could work with talk and text as the core LTE (telus) support it:https://www.gsmarena.com/samsung_galaxy_core_lte_g386w-6846.php

I would try to take out the battery/SIM, and put it back again, and see if it could help.

Or like Goran mentioned, just use a local SIM, it might be cheaper.
(Edited)
Photo of Dwayne_888

Dwayne_888

  • 1,004 Points 1k badge 2x thumb
Try manually selecting the carrier with the one(s) that shows up after you disable "Automatic".