International data not working

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: no longer relevant

I added the 40$ international bundle and the phone and texting works but not the data. Ive tried resetting my phone and i have my data on but it still doesnt work. Anyone know how to fix my problem?
Photo of Phoenix Civiero

Phoenix Civiero

  • 80 Points 75 badge 2x thumb
  • frustrates

Posted 2 years ago

  • 1
Photo of BobTheElectrician

BobTheElectrician

  • 62,198 Points 50k badge 2x thumb
There may be a second setting to turn data roaming off and on as opposed to just mobile data.

1. On some Android phones: Settings=>More networks=>Mobile networks=> make sure Mobile data is checked, which you have already done.

2. In the same window, Network mode => LTE/WCDMA/GSM should be selected while you are on Koodo at home. You can toggle the values and re-start your phone. Sometimes this will fix your problem depending on your local service.
(Edited)
Photo of Phoenix Civiero

Phoenix Civiero

  • 80 Points 75 badge 2x thumb
Ive already tried both of those suggestions before hand and it still didnt work. Thank you for the reply.
Photo of Goran

Goran, Mobile Master

  • 91,244 Points 50k badge 2x thumb
Did you add the data international roaming add-on in self-serve ?
Photo of BobTheElectrician

BobTheElectrician

  • 62,198 Points 50k badge 2x thumb
Check your plan add-ons in self-serve. Enable international voice roaming and international data roaming then restart the phone. Some people have complained they can’t find one or the other add-ons by using the Koodo app on the phone itself. In that case, use your browser and connect to self-serve that way. Both are listed at $0 per month and are needed in order to make any kind of connection outside North America.
Photo of Bernard

Bernard, Official Rep

  • 75,650 Points 50k badge 2x thumb
@ Phoenix, can you put your phone on airplane mode and back please? Looked at your account and fixed what I think was causing the issue. Should work now.
Photo of Alan Baker

Alan Baker

  • 110 Points 100 badge 2x thumb
I am having the same problem as Phoenix. Have tried everything that I could think of plus the suggestions made by BobtheElectrian. I am currently in France and the lack of data roaming is an issue. Any suggestions would be appreciated.
Photo of Goran

Goran, Mobile Master

  • 91,244 Points 50k badge 2x thumb
If you're looking for data, I suggest unlocking your phone and getting this:
http://mobile.free.fr/
Photo of Bernard

Bernard, Official Rep

  • 75,650 Points 50k badge 2x thumb
@ Alan, toggle your phone to airplane mode and back. I made a quick fix to your settings. Should work now.
Photo of Alan Baker

Alan Baker

  • 110 Points 100 badge 2x thumb
Thanks very much - it's working. This is going to save me money as now I don't have to go into a brasserie and order a beer to use my phone. In laymen's terms could you explain the solution and will I need to do this whenever I am overseas?
Photo of Bernard

Bernard, Official Rep

  • 75,650 Points 50k badge 2x thumb
In order to access voice & data internationally you need to enable it. The voice portion was enabled. The data wasn't. It's a free feature (separate from the roaming add-on) that is available in self-serve. Now that it is on though, you will not have to be concerned for future travels. That said, I would strongly encourage consumption of local beverages to make your trips wholesome. :-) 
Photo of Alan Baker

Alan Baker

  • 110 Points 100 badge 2x thumb
I actually did try to enable that feature but was unable to. Thanks for the help. .

This conversation is no longer open for comments or replies.