i cannot make calls on my samsung galaxy s2?

  • 3
  • Question
  • Updated 5 years ago
  • Answered
Photo of Joan Campbell Smith

Joan Campbell Smith

  • 110 Points 100 badge 2x thumb

Posted 5 years ago

  • 3
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
Was it working before and now it's not? We need a bit more info.

Does your phone say "Emergency calls only"? Make sure airplane mode is off, then go Settings > More... > Mobile Networks and make sure "Only use 2G networks" is NOT checked. Then take out your battery and SIM card for about a minute, reinsert them into the phone, turn it on, and try placing calls again. Koodo doesn't use 2G, so having that option enabled basically turns your phone into a small Android WiFi only Tablet.
Photo of Dennis

Dennis, Mobile Master

  • 178,294 Points 100k badge 2x thumb
Can you text?

Does it say no network, if so then try what Jonathan said

This conversation is no longer open for comments or replies.