I was with Telus and now Koodo. I also switched from iPhone to Samsung. I am now not receiving sms

  • 1
  • Question
  • Updated 9 months ago
  • Answered
I was with Telus and now Koodo. I also switched from iPhone to Samsung. I am now not receiving sms from friends with iPhones. Their phones keep trying to send an iMessage - even if they have changed my mobile from iPhone in their contacts. Do I need to change something within my account? I checked under phone in my account and it says unknown. I cannot make the change through change phone options as my sim is entered and it wants me to change that first. But it lists my current sim. When I swtiched they transferred my account from Telus. Most conversations in this group are people switching to an iPhone. 
Photo of Marie Boal

Marie Boal

  • 80 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 106,744 Points 100k badge 2x thumb
Hello Maria


Have you disabled iMessage before switching to Samsung?

If not here's how to do it : https://selfsolve.apple.com/deregiste...
(Edited)
Photo of robert

robert

  • 80 Points 75 badge 2x thumb
Question? When we tried this with the phone number option it says number no longer registered to imessage. We transfered number from old telus plan to new koodo plan
Photo of Daniel

Daniel, Employee

  • 5,712 Points 5k badge 2x thumb
Hi Marie!

Can you confirm if disabling iMessage worked, as suggested by Robert? It should definitely do the trick. 

Thanks :)
Photo of Marie Boal

Marie Boal

  • 80 Points 75 badge 2x thumb
Yes it did work.
Thank you for you help.
Marie