I think The Geek Squad broke my contract with Koodo by replacing my LG G4 with a refurbished FIDO phone.

  • 1
  • Question
  • Updated 8 months ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1866

My phone has no data and my account is now unreachable.
Photo of Eric Mattar-Hurlbut

Posted 8 months ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 107,040 Points 100k badge 2x thumb
I think you would need to contact the Geek Squad because they are the ones who started the problem.
I was trying to get into my account and my name, phone number and password do not match.
Geek Squad has no tech support; just receptionists.
The manager said having a Fido phone will work just fine on the Koodo account.
I guess I'll give them another call.
Photo of Dinh

Dinh, Mobile Master

  • 41,794 Points 20k badge 2x thumb
You would need to unlock that Fido phone before using on Koodo network. Or you could ask the guy at Geek Squad to setup for you, if they say the phone is fine on Koodo network.
Photo of Erwin

Erwin

  • 23,576 Points 20k badge 2x thumb
Hi Eric,

Sounds like they gave you an unlocked Fido LG G4 since you’ve mentioned that only data is not working. For data to work, you will have to configure your APN settings to have data turned on. Go to your settings, the find cellular, more settings, click access point names, press the add button. Then fill up the missing slots with the information provided in this link:

https://www.koodomobile.com/help/sett...

As for the invalid self-serve login, call in to customer service by dialling 1-866-995-6636 or get in touch through Koodo’s Facebook. As them to reset your self serve profile and send you a complete registration email.

Just out of curiosity, when was the last time you logged in to your self serve?
I tried logging in about 19 hours ago. It's my son's phone, so I'll have to wait for him to come home to turn on data. I tried the Facebook question box, about 19 hours ago, but it is still unanswered.
Here, I was given suggestions within the hour, so I guess Koodo tech support is community run.

This conversation is no longer open for comments or replies.