I need some help setting up my phone to use SMS/MMS but NO DATA

  • 2
  • Question
  • Updated 1 year ago
  • Answered
Hi,

I have an LG-P500H phone on koodo, with an unlimted SMS/MMS plan, and data.  I'm the type of user who doesn't want to use data at all (it's overpriced, and wi-fi is free), and the only reason i have data is in the event of a survival related emergency (which thankfully i haven't had to use yet). 

I used to use the standard koodo data Access Point  until i kept seeing extra 5$ data charge on my phone bill, due to sneaky apps that kept turning on and using data, so i have since added a NULL AP entry and set that as default AP.  I haven't had a single data charge since, and that is good.

Even though i can send/receive SMS without a problem, every once in a while someone sends me an MMS that sends an SMS msg with a Download button, and sometimes i would like to take a picture and send it as a quick MMS.  I understand that MMS needs data to be on in order to work.

My question is, is there a way for me to set up my phone's AP settings (or my plan with koodo), so that all data is blocked except for MMS sending and receiving, until i specify that i want to use internet data for emergency use)?  I need to set it up so that it does not send even a single byte to the Internet, which charges me 5$ right then (the first level of paid data package), and essentially block every byte of data EXCEPT FOR MMS messages.

Can anyone help me with this, is it even possible?  I tried doing this before but the results were no good.  Today is my last chance to see if i can get MMS working this way.  I'm in N.S. by the way.

Thanks,
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb

Posted 3 years ago

  • 2
Photo of Robert

Robert, Mobile Master

  • 105,220 Points 100k badge 2x thumb
USING YOUR DATA ONLY FOR PICTURE MESSAGING (MMS)
Brought to you by: The Koodo Mobile Masters with special thanks to Kid Android and Timo Tuokkola.
Can you send regular text messages but not picture messages? 

SIM CARD BASED phones require a data connection in order to send picture messages. So if you, have data turned off or blocked these messages won't go through. "But wait" you say "My plan includes unlimited text and picture messaging and I want to use it but I don't want data because I feel it's too expensive (or whatever)". The Mobile Masters have your solution below. 

-=-
FOR ANDROID DEVICES -=- (for iphone 3GS see Note 2)

STEP 1:

-=-
Navigate to your current messaging app and delete any picuture message you previously tried to send but has failed.

Navigate to Settings / Wireless controls / Mobile networks / access point names

-=-

METHOD 1.
Find the Koodo.sp Apn and tap it to open it. Some phones will allow you to edit this APN, for those phones which will not allow you to edit the default APN (I.E the Samsung Galaxy S2x or The Galaxy Ace 2x),  please skip to Method 2.

Tap APN type and change it so it reads only "mms"   then tap the menu key and select save APN
once saved the 4g indicator should disappear. Please see: Note 1 


METHOD 2

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's 

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: spp.koodo.com
Proxy server:
Port: 
Username:
Password:
Server:
MMSC: 
Proxy server: 
Port: 
MCC : 302
MNC : 220
APN type : default

For APN Type we use "default" for this example but if it doesn't work for you go back and change it to "Internet"
Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.


On the list of available Access Point Names you'll notice three (or more) entries. Select the "Koodo (NoDATA)" apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.
Reboot the phone (Shut it off and turn it back on)
Turn off your WiFi

Do you have data enabled? 
You can enable data by navigating Settings / Wireless and networking / Mobile Network 

Make sure 'use packet data'  or enable data' is checked. 

If you have data blocked by Koodo you'll need to unblock it. You'll have to call customer service (1-866-99-Koodo) to have the block removed. 

After Data is Enabled:

Open your browser and attempt to access any webpage OTHER THAN GOOGLE. You should get a message that the page cannot be displayed. If you do happen to get a web page double check your APN settings and try again.


Note 1: (For Everyone to read)
You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
Just a question about method 2:
APN NAME: Koodo (NoData) APN: spp.koodo.com
^should that be spp.koodo.com?  i'm just asking because it looks like a typo on sp.koodo.com
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
Thanks, i've just set those up, but before i can proceed with this, would you be able to provide me with the default AP settings for the koodo AP used in NS?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Just a heads up that this workaround doesn't work for every device.
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
Are these the ap settings i should have as default:
https://community.koodomobile.com/koodo/topics/access_point_names_settings
?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Yes
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
I understand, I will report back when i test this out for anyone else who has an LG-500Ph, just as soon as i can confirm my default koodo AP settings.
Photo of Robert

Robert, Mobile Master

  • 105,220 Points 100k badge 2x thumb
Perfect! Hope for you that it'll work!
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
Sorry i got a little confused with the layout of the thread and didn't realize the comment feature was reply.  can you confirm that spp.koodo.com is right for the Koodo (NoData) AP?  I would have thought it would be sp.koodo.com
Photo of Robert

Robert, Mobile Master

  • 105,220 Points 100k badge 2x thumb
I think it is sp but I never used it so I'd recommend to try sp first and if it doesn't work go with spp
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Yes it is sp. NOT spp
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
Thanks guys, i tried everything then.

The step 2 for Koodo (NODATA) SP.koodo.com with ap type set as default let all internet through  when set to internet, nothing works.  5$ for 100kb of data coming up :/

Confirmed all settings, this does not work with LG-P500h
(Edited)
Photo of Dennis

Dennis, Mobile Master

  • 191,918 Points 100k badge 2x thumb
You need to set NODATA to SPP.

This will stop the data because then the APN address is wrong.

If you use sp.koodo.com, then that is the correct APN address and data will still work
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
Yeah i tried it both ways, i only asked if SPP was supposed to be SP, because nothing was working at all under SPP
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Nodata apn must be SPP

Make sure the mms apn type is only mms, it should not be selectable.

Only the original Koodo apn and the new nodata apn should be selectable.

Try changing the type from default to internet
(Edited)
Photo of T k A

T k A

  • 216 Points 100 badge 2x thumb
Thanks Chad, i actually did that, like i said double checked the settings, but it's probably like you said, it doesn't work on all phones and mine's one of them.  i've erased them all now, but thanks! 
Photo of Joana Vasconcelos

Joana Vasconcelos

  • 60 Points
So I did this on my new LGG3 and so far so good... I can receive the mms but not go online for what I hope I am not being charged for the data.
But now I can ́t turn on my data in case I need to do it. I tried this method because I didn ́t want to loose all my data with mms. But I still want it to work whenever I need it, What do I have to do to get both things working?

Thanks!
Photo of John McConnach

John McConnach

  • 60 Points
Hi, just did this with my Sky 5.5. Octa and it worked perfectly. thank you!