I just added the International Combo ($40) while in Australia using the app, and it's not working.

  • 2
  • Question
  • Updated 1 year ago
  • (Edited)
I have the "Pay per use international LD" add on, but couldn't find any of the other ones mentioned in the FAQ page to add (International Voice Roaming, International Data Roaming). 

I've had bars ever since I landed (an hour ago), but no texts are coming in or able to go out even after I added the International Combo (30 minutes ago).

I've also restarted my phone, but it didn't help.
Photo of Jessica M

Jessica M

  • 92 Points 75 badge 2x thumb

Posted 1 year ago

  • 2
Photo of Bernard

Bernard, Official Rep

  • 75,644 Points 50k badge 2x thumb
Jessica, can you pls go into your phone settings (I believe under network) and you should see if the phone is on 'automatic'. Toggle that to manual to see if that helps the issue. You have full bars so your phone is working fine. I just wonder if it's something to do with the local carrier.   
Photo of Jessica M

Jessica M

  • 92 Points 75 badge 2x thumb
In the last 30 seconds, I just got a text saying my add on is working. I guess it just got super delayed in the system, so it took over an hour instead of 15 minutes.

Thanks for your suggestion though!
Photo of Bernard

Bernard, Official Rep

  • 75,056 Points 50k badge 2x thumb
Brilliant! Enjoy Sydney, Melbourne, Canberra, the Golden Coast wherever you may be.:-)  
Photo of Amzeel

Amzeel

  • 60 Points
It's always a good idea to add a roaming package before crossing the border, if the package is added, you will get bot text message and email notifications. All you need to do when you don't have network is to take your sim out, reboot your phone, put the sim card back. If this din't work go on settings and reset network settings to switch networks. hope this worked for you. have a nice trip