I have 4G signal and Koodo logo but I can't send or receive any call, text or data.

  • 1
  • Question
  • Updated 5 months ago
  • (Edited)
I just bought a Koodo sim and I have an odd problem with it on my phone. It is a Huawei GR3 dual sim and I have only the koodo sim on it. I have 4G signal and Koodo logo but I can't send or receive any call, text or data. If you dial the number nothing will happen. In the shop that I bought the sim, they tried it on their own phone and it worked but on mine nothing happens except the 4G signal and koodo logo. I called Huawei and they checked everything and they said that since you have signal and the phone seems to be registered in the network, the problem should be somewhere else. I also called koodo twice but it didn't help. I dont know what to do! ;( Anyone has any ideas?
Photo of Vahid

Vahid

  • 120 Points 100 badge 2x thumb
  • sad and confused!

Posted 5 months ago

  • 1
Photo of Dinh

Dinh, Mobile Master

  • 41,784 Points 20k badge 2x thumb
Hi Vahid,
I would try to restart and reset the network settings.
As the phone had 2 SIM, Have you checked if you were using the correct SIM slot for call and data? I would change the SIM into another slot also to check.
(Edited)
Photo of David

David, Mobile Master

  • 93,614 Points 50k badge 2x thumb
According to this link, it will depend on the sub-model of the phone.
The L03 model should work fine, but the L02 is compromised, and the L01 models would not work at all.

Koodo uses the following bands:
GSM: Not supported
3G/HSPA/WCDMA: Band 5 (850 MHz), Band 2 (1900 MHz)
LTE: Band 4 (1700 MHz / 2100 MHz), Band 29 (700 MHz)
Photo of Vahid

Vahid

  • 120 Points 100 badge 2x thumb
The thing is that I have signal. The funny thing is that I just got a voice mail notification form the koodo sim! but I can't access the voice mail (like anything else).
Photo of David

David, Mobile Master

  • 93,614 Points 50k badge 2x thumb
Not a funny thing at all. If your model of phone does not have Band 5 and/or Band 2, you cannot use voice or text as they are on the 3G bands. Data being on Bands 4 and 29 (4G or LTE) would allow data to be sent to your phone. Again, it depends onto sub-model on the phone.
Photo of BobTheElectrician

BobTheElectrician

  • 67,336 Points 50k badge 2x thumb
On many dual SIM phones, one slot is strictly 2G. The frequencies may be right, but there is no proper handshaking going on with Koodo's 3G.

Your handset has the 850/1900 frequencies but only for a 2G network which is not supported by Koodo. The additional frequencies for 3G will depend on your model, as David pointed out.
Photo of Vahid

Vahid

  • 120 Points 100 badge 2x thumb
Since there is only 1 sim on the phone right now, the network setting is on "2G/3G/4G(LTE) Auto" and I have 4G signal. Yesterday I received a voicemail notification (which I can't open!) and this morning, surprisingly, I received 2 texts from Koodo about my self service account and my bill but still nothing works.
Photo of rikkster

rikkster, Mobile Master

  • 68,330 Points 50k badge 2x thumb
To gain a better understanding as to which phone model you have, can you provide the sub-model number of your Huawei GR3? As indicated earlier, Huawei made several variations of this phone. The sub-model number appears as a letter/number combination, (e.g. L01/L21, L03/L23, L13 or L22), which may be printed on a label on the box the phone came in. Or you could go to: Settings > About phone/device and see if the sub-model number appears there.
Photo of Vahid

Vahid

  • 120 Points 100 badge 2x thumb
It's L21.
Photo of Dinh

Dinh, Mobile Master

  • 41,784 Points 20k badge 2x thumb
@Vahid: from the Huawei website: https://consumer.huawei.com/en/phones/gr3/specs/

The model L21 has 2G bands: 850 / 900 / 1800 / 1900 MHz but for 3G it has only band UMTS B1 (2100) and B8 (900).

Those 3G bands didn't support Koodo voice/text (need 850/1900 3G). Your phone properly can connect to Koodo LTE with Band 7, and received text messages from that. 

I guess, if you want to use phone on Koodo network, you might need to change the phone to a compatible one.
(Edited)