I can't get USA Prepaid date to work

  • 1
  • Question
  • Updated 1 year ago
I can't get USA prepaid data to work. I connected to at&t network, data roaming is turned on. Texting is working. I purchased 500mb data us addion but no internet pages/email work. I'm in Palm Springs and I need data!. Yes I rebooted numerous times. My partner's phone isn't getting data either. We have iPhones 6/7. Is there a toll free number to call? Can I get a refund as this is a waste of my time!
Photo of gary

gary

  • 292 Points 250 badge 2x thumb
  • angry

Posted 1 year ago

  • 1
Photo of Bernard

Bernard, Official Rep

  • 81,048 Points 50k badge 2x thumb
Gary, if you are able to text then your phone and account work. No Canadian provider owns any network in the US, we all use whose network is available based on your location. Not sure who the carrier is you see on your phone but it's highly likely that their data speed in Palm Springs seems to cause the slowness. You might try in your settings to manually search another carrier see if theri signals are stronger. 
Photo of gary

gary

  • 292 Points 250 badge 2x thumb
As I said, AT&T is the network and it's not slow - I don't get any data. What carrier should I be connecting to?
Photo of Sophia

Sophia, Mobile Master

  • 142,984 Points 100k badge 2x thumb
What are your APN settings? You can try to connect to any network that is visible in the manual search but I'm wondering if your settings are correct.
Photo of gary

gary

  • 292 Points 250 badge 2x thumb
Sophia - I don't see your reply but I got it in an email . My apn settings are sp.koodo.com. What should it be for att or T-Mobile?


Sophia:

"What are your APN settings? You can try to connect to any network that is visible in the manual search but I'm wondering if your settings are correct."
(Edited)
Photo of BobTheElectrician

BobTheElectrician

  • 67,236 Points 50k badge 2x thumb
AFAIK, the sp.koodo.com settings are the correct ones to use, even if you are showing T-mobile or AT&T as the carrier in your notification bar.

Works fine for 2 phones in Arizona on Android 4.4 and 6.0. No experience with iPhone.
(Edited)