I cannot make or receive calls nor access voice mail. I am in Florida and added Easy Roam before my trip.

  • 1
  • Question
  • Updated 5 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

iPhone5, Florida. I live in Calgary.
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb

Posted 5 months ago

  • 1
Photo of Allan

Allan, Mobile Master

  • 61,910 Points 50k badge 2x thumb
Do you currently have any service?
Have you tried restarting your phone?
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
Yes and yes.
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
This has happened before when I’ve been in the States but I didn’t have time in those trips to fix it.
Photo of Goran

Goran, Mobile Master

  • 96,868 Points 50k badge 2x thumb
Do you have international pay per use long distance, international voice roaming added in self-serve? Is roaming enabled in your phone settings?
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
I really need to have my phone working today for making calls and tomorrow when I’m on the road.
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
I added Easy Roam and got the confirmation text when I landed. Roaming enabled.
Photo of Goran

Goran, Mobile Master

  • 96,632 Points 50k badge 2x thumb
Did you check in self-serve for the three add-ons I named? Also be aware that resetting network settings will also delete all WiFi and Bluetooth credentials.

Which network do you show as connected to?
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
I have as part of my plan the added US Plan. I am on the AT & T network and texting is no problem.
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
Are you still there, Goran?
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
My international data and voice roaming are 2of my current add ons.
Photo of Goran

Goran, Mobile Master

  • 96,632 Points 50k badge 2x thumb
Hmm. Those two are the important ones. Can you out the sim card in another phone if at all possible? See if the problem follows.

Did you reset network settings yet?
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
Any suggestions?
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
I don’t understand I just checked my current add ones in Self Serve and Easy Roam isn’t listed but I got a confirmation text when I landed in Minneapolis where I changed planes.
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
Just tried to add and got a message that I already have it on my account.
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
I cannot see the international pay per use LD nor international roaming as an add on. Can you help me, please?
Photo of Robert

Robert, Mobile Master

  • 106,744 Points 100k badge 2x thumb
Hello there,

Add them (click here to know how) and then turn airplane mode on for 30 seconds and off.

Wish you a wonderful vacation!
Photo of Allan

Allan, Mobile Master

  • 61,910 Points 50k badge 2x thumb
The self serve layout has changed since you made that post to remove the "helpful links" at the bottom. Now you have to click rate plan or choose mobile services from the dropdown.
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
Completed all and still can’t get calls, make calls or get VM.
Photo of BobTheElectrician

BobTheElectrician

  • 67,080 Points 50k badge 2x thumb
Try reset network settings as suggested by Goran above. From Apple support:

https://support.apple.com/en-us/HT201415
Photo of Meg

Meg

  • 170 Points 100 badge 2x thumb
Thanks, Bob. That did the trick.

This conversation is no longer open for comments or replies.