I am not getting full reception since I switched to Koodoo

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I recently switched over to Koodoo to their $34 Canada Wide Plan. Prior to switching I was with Rogers. Rogers had amazing reception but it was expensive. I am currently using the Samsung S3 which I got unlocked. Rogers unlocked it for me since I got the phone from them due to my previous contract.

I put in the koodoo sim card and noticed that I only get 2 to 3 bars out of 4 for reception. I live in Montreal and at times in the subway I get all 4 bars. I get better reception in the subway than I do outside. This is really strange. 

Fido who is also owned by rogers now has the $34 Canada Wide calling plan as well. I am wondering if I cant get better reception with Koodoo maybe I should switch over to Fido.

Anyone know how I can get better reception with Koodoo? Has this happened to anyone before?
Photo of Dee

Dee

  • 70 Points

Posted 2 years ago

  • 1
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Two to three bars should still allow you to make and receive calls. You can try setting your phone to 'WCDMA only' to see if reception improves. Go to: Settings > More settings > Mobile networks > Network mode - select 'WCDMA only'. This will prevent your S3 from scanning for a 2G GSM network which Koodo does not have. Let us know if there's any improvement in reception.
(Edited)
Photo of Jack Yonge

Jack Yonge

  • 2,350 Points 2k badge 2x thumb
Two completely different Networks. Your experience may vary depending on your area and proximity to Cell Towers.

This conversation is no longer open for comments or replies.