I activated my prepaid sim card and the phone shows full signal but unable to dial out or receive phone calls!

  • 1
  • Question
  • Updated 4 months ago
I setup the connection through self serve and all seems okay online. Once I popped the sim card into the phone, it shows full signal but not able to make calls or receive any...
Photo of Neel Nanter

Neel Nanter

  • 100 Points 100 badge 2x thumb

Posted 4 months ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 90,274 Points 50k badge 2x thumb
Did you purchase s base plan and minutes if you picked a plan without calls included? Can you give more details please?
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Are you able to at least text?
Photo of Neel Nanter

Neel Nanter

  • 100 Points 100 badge 2x thumb
No, I am not. The signal shows "emergency".. No calls or text in or out..
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Ok, your original post says you still have full signal.  If it shows emergency, then it doesnt have full signal right?

What phone are you using?  It is compatible with koodo?
Photo of Neel Nanter

Neel Nanter

  • 100 Points 100 badge 2x thumb
Yeah, it does show full signal but also says 'emergency'. I am using a phone that was purchased in Europe. Specs for the phone are in this link: http://www.aligator.cz/products-detail/aligator-v650-senior/118/

Can you tell me if it is compatible with Koodo, please?
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
Yes, phone should work: https://matrixmobile.ca/frequencies/#1471801953395-36f7557b-ea07

Since the phone supports the 850/1900 bands. The fact you're seeing full signal but no connection to Koodo almost indicates the SIM card is not recognized. Can you try taking that out, restart the phone and inserting it again?
Photo of rikkster

rikkster, Mobile Master

  • 66,988 Points 50k badge 2x thumb
Try restarting your phone. Press and hold the power button until you see a menu appear. Choose restart and see if that helps.
Photo of Neel Nanter

Neel Nanter

  • 100 Points 100 badge 2x thumb
I have restarted the phone several times and that does nothing..
Photo of BobTheElectrician

BobTheElectrician

  • 61,576 Points 50k badge 2x thumb
You phone's menus may be different, but in your settings for Mobile Networks, make sure your preferred network mode is GSM/WCDMA. Then under Network operators, seach for available networks and choose either Koodo/Telus or Automatically select preferred network.

If that still does not solve your problem and you are within visiting distance of a Koodo booth, bring your gear in and have your SIM checked with a store phone and your phone checked with a store SIM to isolate any possible hardware problem.
(Edited)