how can I turn off data roaming on my LG- G3 phone? I was told it can be toggled to off, as I live in a border town close to USA

  • 1
  • Question
  • Updated 3 years ago
  • Answered
data roaming near US border
Photo of brian fullarton

brian fullarton

  • 124 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,496 Points 100k badge 2x thumb
Data roaming is typically off by default on android phones, but if you want to check, it's under settings - > more - > cellular networks.
Photo of brian fullarton

brian fullarton

  • 124 Points 100 badge 2x thumb
I have only had this phone a short time but have already been charged $5 for roaming in USA when I didn't leave my home town. Looking at settings the roaming appears off , so why was I charged for this? Seems bogus to me.
Photo of brian fullarton

brian fullarton

  • 124 Points 100 badge 2x thumb
Would there be any advantage to changing Preferred Network Mode from GSM/ WCDMA/ LTE auto to another setting, as related to roaming ?
The guy from Koodo said to switch from Auto to only koodo, but I don't see a setting like that.
Photo of David

David, Mobile Master

  • 93,228 Points 50k badge 2x thumb
There should be an option to select Network Operators or similar in your settings. Scan for the available networks, and choose Koodo / Telus. This will prevent your phone switching to a US carrier.

There has also been an issue recently of 1X data skirting the data roaming switch. If I recall, 1X data is from the old CDMA network. If your $5 charge is for 1X data, you may wish to call Koodo to discuss your bill, especially if you are likely to regularly connect to a US-based carrier while still in Canada.
Photo of brian fullarton

brian fullarton

  • 124 Points 100 badge 2x thumb
Think I found that network setting, switched to Koodo LTE; thanks for that.
Photo of David

David, Mobile Master

  • 93,228 Points 50k badge 2x thumb
Hopefully that setting keeps you off the US carriers. Remember you may need to change it back to automatic if travelling in areas with Canadian partner carriers.

This conversation is no longer open for comments or replies.