Hi, I recently got mobile home phone, it isn't working, need help!

  • 1
  • Question
  • Updated 1 year ago
Hi, I recently got mobile home phone, came with a hub, sim card, I have since gone online and initiated the port of my original home phone number. I have seen something that said this would take 15 minutes and something that said it would take 4 hours. It is the next day and it appears not to be ported, also the hub continues to blink red on what appears to be a tower symbol and all bars, they have continuously blinked since, I have moved the hub all over my home and it does the same thing, is it not detecting wireless? Coincidentally my wife and I have cell phones with Koodo and they both work fine and get full bars, we live close to downtown here, very central, let me know what I should do.
Photo of Hugh Stephens

Hugh Stephens

  • 140 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of David

David, Mobile Master

  • 93,460 Points 50k badge 2x thumb
Porting a home phone number can take a few days. Cellular ports usually occur in the timeline you posted.

Most often a phone is given a temporary number in the short term. This allows outgoing calls, and incoming to the temporary number, until the ported number becomes live.

Can you make outgoing calls on your WHP device?
Photo of Hugh Stephens

Hugh Stephens

  • 140 Points 100 badge 2x thumb
See that's the thing I assumed that I could plug the hub into my normal home phone and dial out, when I pick it up it does give a dial tone but when I put in the number to gives me a muffled series of muffled beeps and never calls anything, do you know why the tower with the bars beside it would be red and always blinking?
Photo of Hugh Stephens

Hugh Stephens

  • 140 Points 100 badge 2x thumb
Ugh, I think I may know what happened, I see in the manual it says that the hub uses a (U)SIM card and shows a picture of the card filling the spot it should go into. However the sim the Koodo sent is smaller than the spot it goes into. I think they may have sent me a micro sim. I also notice the red blinking tower/bars from the manual means check the (U)SIM so I'm pretty sure that is what the issue is. I think I am going to have to call Koodo, this is really annoying, but thanks for helping.
Photo of Hugh Stephens

Hugh Stephens

  • 140 Points 100 badge 2x thumb
Wait...I think a I found a piece that looks like it goes around the sim to make it bigger, it must have fallen off in the box when shipped. I am going to try and see if it fits now.
Photo of Hugh Stephens

Hugh Stephens

  • 140 Points 100 badge 2x thumb
OK it fits now and after restarting the hub it has full signal, it also must be partially ported as I can dial out and it is my landline number but I can't receive calls yet
Photo of Hugh Stephens

Hugh Stephens

  • 140 Points 100 badge 2x thumb
I'll just wait for the number to be fully ported :)
Photo of David

David, Mobile Master

  • 92,780 Points 50k badge 2x thumb
Happy to learn you found a solution. It is funny that the SIM separated in the box. It should have been formed into a Credit card sized unit, from which you would press out the SIM.