Help pls! can’t send text messages unless I have wifi connection. This has been going on frequently, I’m planning to switch provider!

  • 1
  • Question
  • Updated 7 months ago
Photo of Angela Hidalgo

Angela Hidalgo

  • 84 Points 75 badge 2x thumb

Posted 7 months ago

  • 1
Photo of Dinh

Dinh, Mobile Master

  • 33,394 Points 20k badge 2x thumb
What plan do you have? iPhone use wifi to send iMessages and it needs data. If your plan don't have data or you turn it off, you won't be able to send your iMessages (in blue color). iPhone, if you don't turn on the option of using sms when iMessage fails, won't send message to anyone. So that could be your current issue.

Normal text should be in green color in iphone, normally all plan have texts. If you don't care about differences between imessages and normal sms, then turn imessage off. Settings --> Messages --> turn iMessage to OFF
https://www.imore.com/how-to-disable-deactivate-imessage-iphone-ipad

That hopefully will solve the problem
(Edited)
Photo of Angela Hidalgo

Angela Hidalgo

  • 84 Points 75 badge 2x thumb
BRILLIANT!!!!!! I didnt know the color coding! Great info! Big thanks!
Photo of Dinh

Dinh, Mobile Master

  • 33,394 Points 20k badge 2x thumb
Glad that trick helped you, cheers :)
Photo of Dennis

Dennis, Mobile Master

  • 187,758 Points 100k badge 2x thumb
or Settings>Message>Send as SMS if iMessage fails