Having no luck with US Roaming Boosters

  • 1
  • Question
  • Updated 3 months ago
I have a Samsung G5 that was original with Bell and was then unlocked. The phone works fine in Canada and my plan has been active continuously for several years.

I have added US Roaming Talk, Text and Data boosters.
On my phone I have selected Data Roaming.
On my phone I have manually chosen to connect to AT&T.


After connecting to AT&T I can see the tiny 'R' up near the signal strength.
This lasts for maybe one minute then I get a "no" sign (circle with diagonal slash) where signal strength should be and the phone says Emergency Calls Only.

I took screen shots of all this and can upload them if it will help.

This has happened on three different trips to USA.

I have a longer trip planned for end of March and need to get this sorted out.  Any suggestions?

Thanks,
John
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb

Posted 5 months ago

  • 1
Photo of Mats

Mats

  • 21,334 Points 20k badge 2x thumb
Have you ever tried to let it automatically connect to a network instead of manually having it connect to AT&T? 
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb
Yes, but that did not help.  Actually it was the other way around:  when it did not connect automatically I tried manual.
Photo of Dennis

Dennis, Mobile Master

  • 196,006 Points 100k badge 2x thumb
While you are in the US, try to restart your phone and maybe to reset your network settings (Settings>Backup and Reset>Reset Network Settings)

Also make sure your network mode is set to LTE/WCDMA/GSM (Auto Connect)
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb
Will give it a try - thanks!
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb
Now that I have Network Cell Info Lite and Mobile Radio Frequency installed on my phone, is there any information that I should be looking at before I travel next?
Photo of BobTheElectrician

BobTheElectrician

  • 67,162 Points 50k badge 2x thumb
Open Network Cell Info Lite and leave the main screen open. The name of your current provider and signal strength are posted. Your signal should be fairly stable (± 10) and at least in the amber or green zones. If you experience wild swings while you are in a stationary location, there may be a problem with your SIM or handset.

Check the various windows, including the last % connectivity one.
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb
Provider shows LTE Koodo, and signal is steady at -106 in the amber zone (I live in the country).

On the last tab, DEVICE+SIM, it says Roaming: No.  Does that mean I am not roaming at the moment, or does it mean is the SIM or account able to roam?
Photo of BobTheElectrician

BobTheElectrician

  • 67,162 Points 50k badge 2x thumb
It means you are connected to Koodo's home network. If you were in an area served by Rogers only, you would see a little R in your notification bar to indicate roaming, and the numbers would be for the signal from that tower.

-106 is really on the edge of acceptable. I am in a hilly rural area and outside the house I can get -93, but inside the house at my home office, it's more like -103. With that poor a signal, I often don't receive texts right away and the phone will show no service from time to time.
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb
OK, so now I am in downtown boston and I am having no luck,
Data roaming is turned on and I have talk, text, and data US boosters in my account.
If I set the phone to automatically connect it doesn't - just keeps looking.

If I scan and find AT&T I get a strong signal, but when I try to connect I get the message "Your SIM card does not allow a connection to this network"

If it is relevant, I upgraded my phone from a Samsung S3 to a Samsung S5 several months ago by simply moving the SIM over.  Does Koodo need to do something on their end ?

Also, is there a way to get Koodo prepaid help via chat since I can't call with my phone?
Photo of BobTheElectrician

BobTheElectrician

  • 67,162 Points 50k badge 2x thumb
Try pulling the SIM out of the phone and restarting... you'll get an error message but your network connection will be reset completely.

Re-insert the SIM and reboot.

Then:

Settings => More => Mobile networks =>Network Mode: Preferred network mode: GSM/WCDMA

Network operators: Select automatically. Reboot after this selection.

Menus on your handset might be different. I've been bouncing back and forth for the last year or so on prepaid roaming LG G3 without a hitch (rural AZ, VT, QC where the connections are a lot slimmer than Boston).
(Edited)
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb
Tried that and it did not help.  Phone is set to WCDMA/GSM Auto, powered off, remove sim card, power on, power off, replace sim card, power on.

The message is "No Network connection - No signal found for mobile networks"
Photo of BobTheElectrician

BobTheElectrician

  • 67,194 Points 50k badge 2x thumb
Your ongoing problems at home and away suggest a possible problem with your handset or SIM. Send Koodo a private message on Twitter or Facebook, using the logos at the bottom of this page, and see if they can check from their end.
Photo of Goran

Goran, Mobile Master

  • 96,970 Points 50k badge 2x thumb
See if you can try the sim in another unlocked phone and if you end up with the same issues still or not.
Photo of John Jackson

John Jackson

  • 260 Points 250 badge 2x thumb
First off - I would like to thank all of you who helped out.  I am working now.

I called their support number, in all I dealt with five different people, running various tests (same as suggested here).

In the end a "Data Support Analyst, Roaming & IREG" fixed it by "I simply refreshed your provisioning of your services.  Sometimes manually scanning for networks resolves the issue."

Since I manually scanned for networks multiple times, I think it was the "refresh of provisioning of services" that made a difference.

At one point, I was asked to set the network to AT&T and then power cycle my phone six times, then set to T-MOBILE and cycle six more times.  During this time they were running a trace on my phone at Koodo to see what was going on.

Again thanks to all those who helped!
John