Google Play Store - Error retrieving information from server RPC:S-5:AEC-0

  • 3
  • Question
  • Updated 4 years ago
  • Answered
Is anyone else having difficulty with Google's Play Store?

(I couldn't post this as a problem, so I've opted to post this as a question followed by the answer).

This error may appear on some Android devices and prevents users from upgrading or downloading new apps. I found that by downgrading to an earlier version of Play Store, solved the problem.

Here's how to do it:

Go to: Settings > Application manager > swipe to the left until the ALL tab is visible.
Scroll down to and tap Google Play Store, at the top of the page, tap the box labelled Uninstall updates.

Reboot the device and Google Play will revert back to the earliest version, in my case it's 3.10.10. The previous version was 4.1.10. After a couple of updates or app downloads, Play Store automatically reverts back to 4.1.10 and everything works flawlessly again.

Again, this probably isn't happening on every Android device out there, but if someone should encounter this error, this is a tried and true method to get you back up and running on Play Store.
Photo of rikkster

rikkster, Mobile Master

  • 68,304 Points 50k badge 2x thumb

Posted 5 years ago

  • 3
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Glad you found a fix! Thanks for sharing!
Photo of MatB

MatB

  • 32,478 Points 20k badge 2x thumb
This found fix on android forum may also help to get rid of this annoying error:Tap APPS/PlayStore tap MENU button (to the left of your home button) The popup menu has HELP at the bottom. Tap HELP. Scroll down and search "troubleshooting download issues" Read and follow instructions.
Or, you could do what I do: Settings/Storage/UNMOUNT SD card and then MOUNT SD card.

That fixes it for me, the two times it's happened.

When all else fails, read the Help menu of Google Play Store and follow directions,
Photo of Yannick

Yannick

  • 44,018 Points 20k badge 2x thumb
Thanks a lot rikkster! Great job :)

________________________
If you see a good answer, give it a star.
Photo of John Burke

John Burke, Mobile Master

  • 71,346 Points 50k badge 2x thumb
You don't need to reboot.
An easier fix is to clear the App Data from:
-Google Services Framework
-Google Play Store

and uninstall updates for Google Play Store
Photo of Jinson Varghese

Jinson Varghese

  • 60 Points
http://firstandgeek.com/solved-error-... describes very well about this issue.

This conversation is no longer open for comments or replies.