Generic Error trying to activate sim card online

  • 2
  • Question
  • Updated 3 years ago
  • Answered
Just returned from buying a prepaid sim card with a plan at a koodo store. After selecting a phone number to pick out and hitting continue it says:

"Generic Error

Oh no!
It looks like something went wrong, but don’t panic.

Log out and then log back in again to continue. Or return to the Login Page."

Would like to know when they will fix this, id rather not have to give another $15 to this company just to activate it via phonecall. Thanks

Edit: Actually the error happens after the 'Base Plan & Boosters' step
Photo of cordonfreeman

cordonfreeman

  • 110 Points 100 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Petticoat Salty

Petticoat Salty

  • 112 Points 100 badge 2x thumb
Yup, I'm having the same problem. Tried different browsers (Chrome and IE), tried a bunch of times, no success yet.
Photo of Aimee-Lynn Roberts

Aimee-Lynn Roberts

  • 60 Points
This is what's happening to me too.... So frustrating!!!!
Photo of Petticoat Salty

Petticoat Salty

  • 112 Points 100 badge 2x thumb
There's a similar thread here, with no answers:

http://community.koodomobile.com/kood...
Photo of Sophia

Sophia, Mobile Master

  • 142,984 Points 100k badge 2x thumb
Yes no official word yet, sorry guys!
Photo of Petticoat Salty

Petticoat Salty

  • 112 Points 100 badge 2x thumb
Okay, I think it went through for me, I've got to at least the confirmation page...
Photo of Caitlyn McDiarmid

Caitlyn McDiarmid

  • 60 Points
I'm glad I'm not the only person having this problem...
Photo of Khaleila

Khaleila

  • 4,102 Points 4k badge 2x thumb
Hey Cordonfreeman,

The issue has been resolved and we thank you for your patience. You can go ahead and setup your account. Thank you.

________________________
If you see a good answer, give it a star.
Photo of rideshigh69

rideshigh69

  • 62 Points
Apparently we r still having this issue. I got my activation completed and got the error
Photo of Adriana Da Ponte

Adriana Da Ponte

  • 80 Points 75 badge 2x thumb

I just got the same message today?? Is there a fix yet?


Photo of Jacques

Jacques

  • 300 Points 250 badge 2x thumb
I have been getting the same problem for 5 days now. It started happening right after I changed my phone number. Still happening after I cleared my cache, in IE, FFox, Chrome on different PCs and on my cell. Tech Support says that they are upgrading their software/servers... For 5 days?
Photo of John Mullan

John Mullan

  • 80 Points 75 badge 2x thumb
It's never fixed!  There are ALWAYS these complaints.  1 year ago, 4 months ago.  1 month ago.  Now (me)!  They just don't know how to make a good working web site.
Photo of Adam Black

Adam Black

  • 70 Points
I am currently having this issue, get to the select device/plan/booster page and once I select a base plan I get this error.
Photo of Veronica

Veronica

  • 3,528 Points 3k badge 2x thumb
Hey Adam, 

Have you tried clearing your browser's cache/cookies http://koo.do/1HRTNMW or using another browser? 

Let us know how this worked for you!
Photo of Adam Black

Adam Black

  • 70 Points
I couldn't get it to work on an android phone, or a Macbook, but it just worked perfect on a windows pc.

This conversation is no longer open for comments or replies.