Galaxy S4 Autocorrect lost all my remembered words?

  • 5
  • Question
  • Updated 2 years ago
  • Answered
My Samsung Galaxy S4 has suddenly lost all my remembered words, like my children's names, "ok", "hun" etc.. it keeps constantly trying to autocorrect them to something else, when it didn't before. Well up until a few days ago when my 2 year old got ahold of my phone and possibly did something... lol

Any ideas on how to fix?

I checked and predictive text and word replacement are still checked like before...
Photo of Dani Girl

Dani Girl

  • 150 Points 100 badge 2x thumb

Posted 5 years ago

  • 5
Photo of Dennis

Dennis, Mobile Master

  • 196,890 Points 100k badge 2x thumb
It sounds like someone reset your keyboard in settings or the data was deleted in the application manager.

Unless you create backup images of your phone, you wont be able to recover this.

You just have to keep using your keyboard for it to relearn how you type
Photo of Dani Girl

Dani Girl

  • 150 Points 100 badge 2x thumb
Ok thank you I'll keep trying, but it doesn't seem to be relearning them. Hopefully it will as I keep using them. :S

Just wasn't sure if there was something I was missing.

I looked around online and saw several different threads (From the States I think) mentioning to change the keyboard to Swype, but mine only has the option for the Samsung keyboard...
Photo of Dennis

Dennis, Mobile Master

  • 196,890 Points 100k badge 2x thumb
Go to your keyboard settings and make sure your predictive text is on.
Also click on the word predictive text and make sure Personalized data box is checked
Photo of Dani Girl

Dani Girl

  • 150 Points 100 badge 2x thumb
Yes they both are checked Dennis, but thanks for mentioning it.
Photo of Dennis

Dennis, Mobile Master

  • 196,890 Points 100k badge 2x thumb
Also try pulling out the battery and restarting the device. Could help reboot things
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,958 Points 100k badge 2x thumb
Hey Dani, try this keyboard called SwiftKey it's much better than the keyboard that comes stock on any Android device. It has the best prediction of every keyboard after a week or 2 and you can also set many things like what apps it learns from, keyboard key size, theme (colors & slight shape differences) & you can now even place the keyboard anywhere you want on the screen, if you want to have swipe enabled & more plus you can sign in with your Google account and sync your predictions across devices & restore them when getting a new device or resetting the device to a factory state.

Here's a link to the free version to try then if you like it which I'm sure you will you can buy the full version

https://play.google.com/store/apps/de...
Photo of Dani Girl

Dani Girl

  • 150 Points 100 badge 2x thumb
I have tried a battery pull too, no real change.
I don't really want to download an app for it (I don't actually use the swype type function).

I just wish it would autocorrect the way it did a week ago... :(
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,404 Points 100k badge 2x thumb
I second the SwiftKey suggestion. It's the best keyboard I've used on Android and it's always the first app I download when I get a new Andriod, followed closely by the Google Keyboard.
Photo of Dani Girl

Dani Girl

  • 150 Points 100 badge 2x thumb
Thanks for the suggestions all. I'll keep it in mind, but I really don't want to download another keyboard. I generally like the Samsung keyboard, with the number row etc.d

I've always been using this one, it just seems like it's been wiped and doesn't seem to be relearning anything.... I have Predictive Text turned on, and have even tapped on the 'Learn From Messaging' many many times, but still doesn't seem to be learning my regularly used words really. *Sigh*
Photo of Some random Mobile Master

Some random Mobile Master, Mobile Master

  • 39,554 Points 20k badge 2x thumb
Swiftkey here too! And since they added cloud support, your custom dictionary is always there waiting for you :)
Photo of RedMageX

RedMageX

  • 2,908 Points 2k badge 2x thumb
Google keyboard is a good free alternative also. I've been using it in favor of SwiftKey and I don't see much difference between the two
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,958 Points 100k badge 2x thumb
Don't remember if it does or not but check if there's an option under the phones settings menu in the language and input section to re sync your keyboard.
If not then go to the settings menu again but click on your Samsung account under the accounts section then click the account and check for an option for keyboard there and make sure it's checked off. Then at the top right corner tap sync and it should sync your Samsung account to the device an keyboard if there indeed was an option.
Photo of Anneke Marie

Anneke Marie

  • 60 Points
Hi I don't know if you figured it out yet but I was having the same issue. I like my Samsung keyboard but it wasn't saving words. Just reset it. Go into settings, language input, click the settings cog by Samsung keyboard and down at the bottom is a reset. Click that and it will start to save your words again. Hope this helps.
Photo of Shaimaa Elsamny

Shaimaa Elsamny

  • 60 Points
THK U ,,,, u helped me alot
Photo of Alex Ware

Alex Ware

  • 60 Points
Perhaps the 'update with new and popular words' box should be unchecked. I find that my personalised keyboard seems to spontaneously forget everything without a restart or any input from me. A scheduled update could be the reason.
Photo of Afaq Haider

Afaq Haider

  • 190 Points 100 badge 2x thumb
This is not done by what you think, its by some update, that had also crushed my SKB, i did the following, mine is working fine now.

Settings>Application Manager> All(Tab)>Samsung Keyboard>Clear Data> Restart Phone (by shutting down> removing battery, inserting battery, Power on)

But please note, you will have to resave all personalized data, other settings should be to your convenience,
Mine are,
Settings,>More(Tab)>language and input>Keyboard Samsung>
Language >English US
Predictive Text >on
Auto replacement> off
Auto Capitalization> on
Auto Spacing> on
Auto Punctuate> on

Keyboard Swipe None
Sound>off
vibrate>off
Character Previw> on
Photo of Barry Carter

Barry Carter

  • 60 Points
Go to settings, Application manager and slide the bar at the top to ALL then scroll down to Samsung Keyboard. Select it and click CLEAR DATA. Then go back to home screen, select settings, MY DEVICE and scroll down to Language and input. Click it then click Sansung Keyboard and then click Predictive text. Turn on the feature and click one of the learning options. I used the Learn from messages.

After that go to home screen and everything should be fine.

This conversation is no longer open for comments or replies.