Galaxy S2 won't receive MMS.

  • 2
  • Question
  • Updated 5 years ago
  • Answered
Picture Messages sent from my S2x are received by iPhones and older Galaxy S2 phones but my S2x never receives MMS from anybody.

I have tried every tip - turn on data - turn off wifi - reset APN ddefaults - update operating system - no luck.
Photo of Bruce Douglas

Bruce Douglas

  • 90 Points 75 badge 2x thumb

Posted 5 years ago

  • 2
Photo of Curtules


  • 19,666 Points 10k badge 2x thumb
Are you able to send MMS or use data in general?

Is auto retrieve on in the messaging settings? That could be it.

Otherwise I'd contact tech support for more help.

Edit: I misunderstood the post, I thought you were talking about two different phones, an S2 and an S3. check the messaging settings though.
Photo of Nicole Whitewood

Nicole Whitewood

  • 60 Points
Here's what I had to do.. (it took me almost 2 hrs to figure it out..)

Settings > More.. > mobile networks > APN >
Make sure your APN network has the following settings. If not, create a new one.

Proxy server:
Port: 80

Proxy server:
Port: 80
MCC: 302
MNC: 220

APN type: Internet + MMS

Save, then back at the "Mobile Network" page there's a box called:
"Use packet data" ... make sure it's checked.

That should do it!!

That's honestly the only thing that worked for me, and I went through all the other settings, along with all the settings in my messaging apps.

Good Luck!

This conversation is no longer open for comments or replies.