galaxy ace not texting on data

  • 1
  • Question
  • Updated 4 years ago
  • Answered
My galaxy ace isn't letting me send text while using data. I've tried taking the sim card and battery out for 15 Miranda it still does it. any ideas what it could be and how it can be fixed, if it can be?
Photo of Christien Garnett

Christien Garnett

  • 110 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Christien Garnett

Christien Garnett

  • 110 Points 100 badge 2x thumb
Minutes*
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
This is a design flaw that Samsung chose not to fix. I believe if you turn your wifi on and then off again, it will work
Photo of Christien Garnett

Christien Garnett

  • 110 Points 100 badge 2x thumb
I've tried sending it with the wifi on and off still didn't work. Have to keep my data off. I can send text while using my wifi. Are Samsung doing anything about it?
Photo of Marcus Fenix

Marcus Fenix

  • 15,752 Points 10k badge 2x thumb
Hi Christien - Not likely. The Ace has been out for about 2 years now(give or take) and there has yet to be any word on a fix. Since the ace appears to be the only phone with this issue I doubt they are investing time/money on getting this issue resolved.
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Samsung has said that it has no plans on fixing it
Photo of Melissa Wright

Melissa Wright

  • 70 Points
Hey, ive had the same problem.. They say its occurin with a lot if phones when I called in and they are workin on the problem... But for now if u keep usin the wifi and data is on and u turn off the wifi. Ull have to take your battery out...
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
You do realize you both posted at the same general time. It's possible Ahmad just overlapped. Keep it civil ppl. We have a lot of new eyeballs staring at us.
Photo of Iglooman

Iglooman

  • 4,090 Points 4k badge 2x thumb
Other reports have said texting while WiFi is on should work, or switching your phone to 2G mode should allow you to text while using data.

What version of Android are you running? Go to settings>About Phone and "Android Version".

There's details about the problem and people working on fixes here: http://androidforums.com/samsung-gala...
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,972 Points 100k badge 2x thumb
I can guarantee that setting the phone to 2G will not work with koodo, since koodo does not have a 2G network.
Photo of Brad

Brad

  • 480 Points 250 badge 2x thumb
My brother and I both have Samsung Galaxy Aces. He also has problems with texting while data is activated. No problem when wifi is on though.

One trick to help out with the data texting problem is to get a little widget on your homepage that turns the data network on and off. It is a little tedious at times but it's the price you pay for a cheaper phone.
Photo of Christien Garnett

Christien Garnett

  • 110 Points 100 badge 2x thumb
I heard it was a great phone when I went to buy it.
Photo of Iglooman

Iglooman

  • 4,090 Points 4k badge 2x thumb
I've found it a great phone, although the internal memory is low and I'm starting to hit issues with that, I don't use data, only WIFI, so I haven't hit this issue except for the month Koodo tried to entice me into getting a data package by giving me free data for a month. Sound like you are stuck with a widget to turn off data when you want to text, or be brave and try to upgrade to 2.3.6 like the thread I posted above mentioned near the end. Haven't found confirmation in Canada that it works on the Koodo network though. How old is your phone? If you just got it, you might be able to trade it at the Koodo shop for a different phone without a penalty due to the issue. Overall, for the price, it's a great phone, but now eclipsed by several others, like the Galaxy Ace 2 X offering more memory and Android 4.0 for the same old price of the Galaxy Ace.
Photo of Camilo_A

Camilo_A

  • 31,012 Points 20k badge 2x thumb
You can download a widget called DATA ENABLER, this will not solve the issue, but it is a shortcut for you to enable/disable data just by tapping on an icon that you can install on the home screen... will help you to save time...
Photo of Steve

Steve

  • 4,030 Points 4k badge 2x thumb
I also find widgetsoid which does this (providing a data on off toggle widget) and so very much more to be very useful. Instead of just turning something on or off, it's features have features :) Worth a look.
Photo of Christien Garnett

Christien Garnett

  • 110 Points 100 badge 2x thumb
I am running 4,3.4 on my phone.
Photo of Ollistopheles

Ollistopheles

  • 824 Points 500 badge 2x thumb
It is all texts or just picture texts? My wife had a similar problem with her Ace, and I believe the issue was resolved by making sure that the full phone number (eg: 1-902-xxx-xxxx) was put in. Hopefully that helps.
Photo of Bene Smiles

Bene Smiles

  • 236 Points 100 badge 2x thumb
Just to clarify, with koodo you must have data or wifi on just for texting???
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
No you don't, you just need to have 3g enabled and be connected. You only need data for mms . :)

This conversation is no longer open for comments or replies.