Galaxy Ace- Data/Calls/Texts problem.

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866

My Samsung Galaxy Ace randomly receives texts and cannot send them, additionally, I can only make phone calls at random times. I have tried a battery pull & re-inserting the sim card. I have also tried unchecking packet data, and re-entering APN settings. Any solution?
Photo of Angelo Yelda

Angelo Yelda

  • 90 Points 75 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 1
Photo of Reena

Reena

  • 4,244 Points 4k badge 2x thumb
Hi Angelo

Have you taken the phone to a kiosk to have it looked at? It could be your sim card and the kiosk could use their demo phones to test your sim.
Photo of Camilo_A

Camilo_A

  • 31,072 Points 20k badge 2x thumb
Hi Angelo... When you see that your text messages are failing when sending them, try to resend them but make sure that your data is off, like this they wont fail...

You may also back up all your info to your computer and try doing a factory reset, most likely will help, your phone will start fresh and you can set it up again, make sure that you have a SD card to save your photos and pictures so you don't use the internal memory...
Photo of Angelo Yelda

Angelo Yelda

  • 90 Points 75 badge 2x thumb
I have done two factory resets and have already turned off data, as I mentioned.
Photo of Jennifer Tewnion

Jennifer Tewnion

  • 224 Points 100 badge 2x thumb
I also have this issue. was told it should work without data, but I cannot send or recieve picture messages >.<
Photo of MykeC

MykeC

  • 20,174 Points 20k badge 2x thumb
Hey Jennifer, mobile data must be on in order to send & receive pictures. That is how MMS works on the HSPA network.

________________________
If you see a good answer, give it a star.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Turn the data off (settings, wireless and networks, un check "Enable packet Data") when you want to send a text. There's a known issue with the ace that Samsung has decided not to address.

Let us know.
Photo of Angelo Yelda

Angelo Yelda

  • 90 Points 75 badge 2x thumb
As stated, I have already done this. This is no fix to my situation.
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
In that case, Reena's solution is the only option still left for you :)
Photo of Jorden

Jorden, Mobile Master

  • 33,404 Points 20k badge 2x thumb
Have you called in to talk to Tech Support yet? Sometimes messages get clogged up on the back end and they need to do a reset.
Photo of Sherilyn Boney

Sherilyn Boney

  • 60 Points
My son also has a Samsung Galaxy Ace and I got the text plan for traveling to the states and it doesn't work!
Photo of rikkster

rikkster, Mobile Master

  • 67,084 Points 50k badge 2x thumb
Your best option is to contact tech support. There isn't much we can suggest to resolve the problem. There may be an issue with the plan itself or the Galaxy Ace may be acting up. Tech support is reached by pressing 6 on your dialpad.

Customer Service: 1-866-99-KOODO (1-866-995-6636) or 647-788-4337.

Hours of Operation:

Monday – Friday: 10 am - 9 pm
Saturday: 9 am - 7 pm
Sunday: 9 am - 7 pm

This conversation is no longer open for comments or replies.