Galaxy Ace 2 not switching automatically between wifi and 4G

  • 1
  • Question
  • Updated 5 years ago
  • Doesn't Need an Answer
Galaxy Ace 2 wifi issues - regualrly doesn't autoswitch between wifi and 4G. My phone often stays stuck on a wifi network even though I am well out of range and doesn't switch to 4G or the opposite, it doesn't switch automatically to saved wifi networks. WiFi on during sleep is on. Very annoying, especially when it won't switch to 4G
Photo of stuart.paynter

stuart.paynter

  • 230 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 196,100 Points 100k badge 2x thumb
Try popping out the battery for a few mins and putting it back in and turning it on and trying again to see if it fixes the problem
Photo of stuart.paynter

stuart.paynter

  • 230 Points 100 badge 2x thumb
I've tried this a number of times.
Photo of Dennis

Dennis, Mobile Master

  • 196,100 Points 100k badge 2x thumb
Try the menu here to control wifi when you phone goes to sleep. Not sure it this will help with the wifi to cellular data.

Settings -> Wireless Controls -> Wi-Fi settings -> Hit "Menu" and select "Advanced"
-> Wi-Fi Sleep Policy

Also I do not believe the Ace 2 has 4G. Make sure your 3G is enabled too
Photo of stuart.paynter

stuart.paynter

  • 230 Points 100 badge 2x thumb
I have it so the wifi stays on when the phone goes to sleep.

Also, you are probably right about 3G vs 4G but the "4G" symbol is displayed in the notification bar when it switches to mobile data.
Photo of Dennis

Dennis, Mobile Master

  • 196,100 Points 100k badge 2x thumb
I did read about a known android issue when wifi stays on too long. Can you try it so that wifi turns off like 15 mins after sleeping to see if this solves your problem?

Were you able to enable 3G?
Does your calling texting work?
Photo of stuart.paynter

stuart.paynter

  • 230 Points 100 badge 2x thumb
Mobile data is enabled, there's no option for type of service, and it works, when it switches.

The most annoying case is leaving home and getting to work to see that it is still "connected" to my home wifi even though that's over 20km away. It will stay like that with no data service until you either connect to another wifi network, or turn it off to connect to mobile data service.
Photo of Dennis

Dennis, Mobile Master

  • 196,100 Points 100k badge 2x thumb
during that time does calling and texting work?

Is your android OS up to date?

You can also try a factory reset but you should back up all your stuff first if you attempt this or you will lose it all

Is your phone under a year old? If so there is the warranty option if you bring it to a koodo kiosk.

This conversation is no longer open for comments or replies.