Galaxy S7 works slowly and drops on wifi and lte

  • 2
  • Question
  • Updated 2 years ago
  • Answered
My galaxy S7 sucks as far as making what's app of Facebook calls they drop etc. Glad u didn't sell my S4 of use that to get a good connection. Be returning my S7 not worth it at all!!
Photo of Bradley Ryver Steffensen

Bradley Ryver Steffensen

  • 460 Points 250 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 2
Photo of Chadwick

Chadwick, Mobile Master

  • 33,012 Points 20k badge 2x thumb
Hi Bradley, im having a hard time making out the whole problem your having. Could you explain that again .
Photo of Mayumi

Mayumi, Mobile Master

  • 111,060 Points 100k badge 2x thumb
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 192,846 Points 100k badge 2x thumb
Have you tried a factory reset and clearing your system cache after making sure it's updated to the most recent version of Android available for the device at the moment
Not factory reset no. Buy up to dress and cleared cashe. Anyway online had the phone for a few days
I meant updated not up to our dress that's auto correct for ya
Photo of Mesmashh


  • 670 Points 500 badge 2x thumb
My s7 edge was going wonky after a update, kept turning off the WiFi setting or it would stay connected to a WiFi even thought I wasn't in range ... I had to clear my WiFi settings.
How do I do that ?
Photo of rikkster

rikkster, Mobile Master

  • 66,210 Points 50k badge 2x thumb
'Forget' the Wi-Fi connection. Go to: Settings > Wi-Fi - press and hold the connection you want, then selecting “Forget”. Re-enter the password and try again. Go into the Advanced settings in the Wi-Fi menu of the phone, and look for Wi-Fi frequency band. Change it from the default automatic selection to 2.4 GHz only. Go into Wi-Fi > Settings > Advanced; make a note of your device MAC address, then make sure that the phone is allowed access in the router’s MAC filter.

LTE - try selecting a different network type. HSPA+/UMTS or WCDMA only, whichever is displayed, either selection will work and should improve signal reception. To change network types go to: Settings > More > Cellular networks > Preferred network type and make the selection there.
Photo of Anna


  • 6,126 Points 5k badge 2x thumb
Hey Bradley! Did everyone's suggestions help? Keep us posted!
No I'm gonna go to the store when I have gone may bring phone back. Way to frustrated

This conversation is no longer open for comments or replies.