Galaxy s6 has no service

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

My samsung galaxy s6 lately has been saying "Emergency call only" It's been doing this for about 2 days now. I bought a new sim card and that did not work. I got service randomly again, and after a few hours it says "unregistered sim" when I registered it already.
Photo of Reshmi Chandra

Reshmi Chandra

  • 70 Points

Posted 3 years ago

  • 1
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,270 Points 100k badge 2x thumb
Do you have a case on it? If you have a metal framed case they are known to kill the reception on the S6 pretty bad.
Does it lose reception everywhere or only in certain areas?
Did you purchase it from Koodo or elsewhere?
Photo of Dave

Dave

  • 7,814 Points 5k badge 2x thumb
Since it sounds like you are getting random service with your phone, I would suggest calling technical support - they should be able to help, including submitting a trouble ticket for the problem if need be.

Paul has some good questions that tech support will also ask (just so you know), and they will probably have you do things that you have already done - please bear with them, as they have a checklist of things for each problem before they can submit a trouble ticket.

One of the things would be pulling the battery and SIM card or putting the phone in airplane mode so call them from another line please - the number is 1-866-995-6636 (or *611 if it is another Koodo phone)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
First thing to try is powering down your device and removing the sim card and, if possible, the battery Wait a minute and then reinstall the sim and battery. Restart your device.

Didn't work?

Check and be sure you're not in Airplane or Flight Mode.

Still not working?

Navigate to your settings and mobile network settings.

Be sure that:
Network Selection is set to Automatic
USE 2G Only or USE GSM ONLY isn't selected

Network type typically should be "GSM\WCDMA PREFERRED"

Still not working?

Change NETWORK SELECTION to Manual
The device will perform a scan which could take up to 2 minutes. You'll be presented with a list of available networks. Choose Koodo or Telus from this list.Note: Doing this disables international roaming. Should you ever want to roam in the future you'll need to change this setting back to automatic

If your device still isn't working, check and be sure your bill is paid up and then give Tech support a call. It's free.

You can reach Customer Service at 1-866-99-KOODO (1-866-995-6636) or 647-788-4337.
Hours of Operation
Monday - Friday: 10am - 9pm
Saturday: 9am - 7pm
Sunday: 9am - 7pm

This conversation is no longer open for comments or replies.