Galaxy S4 won't connect to wifi because of : Your connection is not private

  • 1
  • Question
  • Updated 9 months ago
  • (Edited)
I'm having trouble connecting to wifi networks. Everytime I try with my samsung galaxy S4 it connects, but then doesn't let me sign in into the networks and says : Your Connection is not private. Any ideas on how to solve this problem? Thanks! (p.s I've tried clearing the data from the google chrome app, and adjusting the time and date automatically...)
Photo of Pascale Lemay

Pascale Lemay

  • 70 Points

Posted 9 months ago

  • 1
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Hi Pascale, have you tried clearing the the browsers' cache? Sounds like you're able to connect to Wi-Fi. The trouble seems to be with accessing Chrome. If the steps in the guide below fail to resolve the issue, you may need to perform a factory reset on your S4.

http://www.zerodollartips.com/your-connection-is-not-private-android/
Photo of Goran

Goran, Mobile Master

  • 90,970 Points 50k badge 2x thumb
There's always trying another browser as well.
(Edited)
Photo of Robert

Robert, Mobile Master

  • 103,858 Points 100k badge 2x thumb
I think you may receive this message because you're time and date are not set up correctly, I know that I had a problem when I was trying to access internet and that my time and date were off.