Galaxay S2 shows wrong time

  • 1
  • Question
  • Updated 5 years ago
  • Answered
My samsung galaxy s2 show time 1 hour behind. I've tried enabling/disabling flight mode. Checked that nothing funny with the time zone setting ect. It is set to get the time from the network & on startup will intially show the correct time before reverting back an hour.

The alarm however works to be set to the current correct time... Weird.
Photo of Steve MacDonald

Steve MacDonald

  • 132 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of John Lee

John Lee

  • 36,724 Points 20k badge 2x thumb
Hm, that's weird. Try restarting the device. By adjusting the time zone settings, you should be able to fix the clock.
Photo of Steve MacDonald

Steve MacDonald

  • 132 Points 100 badge 2x thumb
Have re-started & pulled the battery about 20 times.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,908 Points 100k badge 2x thumb
Do you have the daylight savings time option checked off if it has one?
Photo of rikkster

rikkster, Mobile Master

  • 68,380 Points 50k badge 2x thumb
Try going back into Settings > Date and time and enable Automatic time zone (Use network-provided time zone). I have no idea where you're located, but for Ontario, I'm showing GMT -4:00 Eastern Daylight Time. Could be a network glitch in your area. Keep us posted.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Are you on wifi? Have you set the time.on your router correctly?
Photo of Steve MacDonald

Steve MacDonald

  • 132 Points 100 badge 2x thumb
Thanks for your help guys. I had tried many of the above suggestions about a month ago with no success. It seems that this time around I was able to manually change the time zone and it has seemed to stay -- previously this wasn't the case. Thanks all!

Before the automatic time zone was causing issue and manually changing it didn't work... Works great now.

(Edited)

This conversation is no longer open for comments or replies.