FIX: Samsung Galaxy S6 Not Receiving Calls On Android 5.1.1 with WiFi

  • 3
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
EDIT:
Apparently, if you are connected to your Wifi, and have NOT dialed out for a while (a few minutes - hour) you won't be able to receive calls until you dial another number.

Therefore, this fix only works for phones that are idle, (hence wifi is automatically turned off) but if you are actually using your phone with wifi - this still occurs

Pretty serious bug if you ask me


There has been in the issue with the new Android 5.1.1 Samsung Galaxy S6 update where:

Similar thread here:
https://community.koodomobile.com/koodo/topics/samsung-galaxy-s6

1. Phone calls are not logged - when phone is idle & connected to Wifi
2. When people call you they go instantly to voicemail
3. You get no missed call alerts
4. You get instant voicemail notifications.
5. You don't get new text messages

Koodo should be on top of this but they are not.

This is a issue with either the Android Software or the Koodo Network because Koodo DOES NOT support "Wi-Fi Calling" (There is no option in the Settings for S6 @ Koodo) therefore you can't enable or disable it.

Fix
------
The fix is to not have Wifi on when the phone is idle/sleep. change your Wifi settings below to the screenshot below.

Settings -- > Wifi -- > MORE -- > Advanced -- > "Keep Wi-Fi on during Sleep = Never"
I also have "Network notification" and "Always allow scanning" enabled.



----
Photo of Asaad

Asaad

  • 202 Points 100 badge 2x thumb

Posted 3 years ago

  • 3
Photo of Bobbi

Bobbi

  • 142 Points 100 badge 2x thumb
This hardly seems like a "fix" when you are forced to burn through your data and then get charged extra when you go over your limit. Hopefully this issue will be addressed soon.
If wifi is off only during sleep then you won't burn through data.. I have mine set do download app updates only when charging and with wifi connected.