FIX: Samsung Galaxy S6 Not Receiving Calls On Android 5.1.1 with WiFi

  • 3
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
EDIT:
Apparently, if you are connected to your Wifi, and have NOT dialed out for a while (a few minutes - hour) you won't be able to receive calls until you dial another number.

Therefore, this fix only works for phones that are idle, (hence wifi is automatically turned off) but if you are actually using your phone with wifi - this still occurs

Pretty serious bug if you ask me


There has been in the issue with the new Android 5.1.1 Samsung Galaxy S6 update where:

Similar thread here:
https://community.koodomobile.com/koodo/topics/samsung-galaxy-s6

1. Phone calls are not logged - when phone is idle & connected to Wifi
2. When people call you they go instantly to voicemail
3. You get no missed call alerts
4. You get instant voicemail notifications.
5. You don't get new text messages

Koodo should be on top of this but they are not.

This is a issue with either the Android Software or the Koodo Network because Koodo DOES NOT support "Wi-Fi Calling" (There is no option in the Settings for S6 @ Koodo) therefore you can't enable or disable it.

Fix
------
The fix is to not have Wifi on when the phone is idle/sleep. change your Wifi settings below to the screenshot below.

Settings -- > Wifi -- > MORE -- > Advanced -- > "Keep Wi-Fi on during Sleep = Never"
I also have "Network notification" and "Always allow scanning" enabled.



----
Photo of Asaad

Asaad

  • 202 Points 100 badge 2x thumb

Posted 3 years ago

  • 3
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 206,708 Points 100k badge 2x thumb
Not had a single issue with either my s6 or s6 edge on Koodo and many others here I know have not mentioned any issue like this at all either with their S6 or S6 Edges
(Edited)
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 206,708 Points 100k badge 2x thumb
Is your S6 from Koodo or one that you brought to Koodo as an unlocked device ?
Photo of wrxy265

wrxy265

  • 90 Points 75 badge 2x thumb
Are you on 5.1.1 and did you test it? It took me a while to notice this issue, as well. You need to be connected to a wifi network; it's not enough to just have wifi on.

The better workaround for this issue is just to use the WCDMA/GSM option of your mobile networks settings. This will avoid you having to toggle wifi on/off all the , but you will lose lte connectivity.
Photo of Asaad

Asaad

  • 202 Points 100 badge 2x thumb
I got mine from Koodo, and i have it on 5.1.1. Sometimes this occurs on the WCDMA/GSM option as well.
Photo of Michelle Minshall

Michelle Minshall

  • 344 Points 250 badge 2x thumb
This exact same thing has been happening to me since the update, I've only had this phone since June. I've changed the WiFi and the data just now accordingly to these suggestions. Hopefully it works cause my phone hasn't been receiving texts for almost 5 hours. I find if I send myself a text message I will get all the messages that haven't come through since then. But sometimes, I never receive the texts from myself either. It's extremely frustrating!
Photo of kenny azn

kenny azn

  • 914 Points 500 badge 2x thumb
5..1.1 is also broken on my S6 edge, My LTE keeps disconnecting or takes much longer to send a text or messege. The same thing happens on my friend's S6 edge. My edge was perfect before the update.
Photo of Dacian Toncescu

Dacian Toncescu

  • 252 Points 250 badge 2x thumb
I have the same problem.
I called koodo several times.
Nothing happened.
Photo of Bobbi

Bobbi

  • 142 Points 100 badge 2x thumb
This hardly seems like a "fix" when you are forced to burn through your data and then get charged extra when you go over your limit. Hopefully this issue will be addressed soon.
If wifi is off only during sleep then you won't burn through data.. I have mine set do download app updates only when charging and with wifi connected.
Photo of nikki

nikki

  • 60 Points
Im having the same issue my husband tried calling me one morning six times, my phone did not ring nor did i have any recent missed calls in my call history from him. this has now happened twice! he should me his call log and all his calls he placed to me were there but my phone did not ring at all!  im a galaxy s6 edge plus user 
Having same issues at work and home wi-fi phone calls go straight to voicemail if I don't use my phone enough. I'm having this issue with telus so may not be a koodo issue but a samsung problem 
I have the same issue and I am with Telus. Telus sucks to being with and I don't plan on turning off my wifi at work or at home just to get phone calls and texts, this is stupid. Ill start getting charged out of the ass on data if I do that. This is not a fix. This is still a huge issue especially for people like me who use their phone for 90% work and I cannot afford to miss phone calls or texts, this is very frustrating.
Office calls and text messages don't use much data really. Browser, Facebook and especially youtube use a fair bit. Basically when your screen is off and or your phone screen is locked there isn't much data usage to worry about.
Photo of Kreme DeLaKreme

Kreme DeLaKreme

  • 90 Points 75 badge 2x thumb
It's not just Koodo, I have the exact same issue on TELUS and I saw this post about Rogers: http://mobilesyrup.com/2015/10/09/and...
Photo of Tina Miskey

Tina Miskey

  • 60 Points
I am having this issue with my S6 and it just started on Thursday.  Calls go straight through to VM even when I am not on wifi and I have not been getting my text messages until I am off a wifi network and start using my phone.  This 5.1.1 update issue needs to be fixed ASAP.
Photo of Kreme DeLaKreme

Kreme DeLaKreme

  • 90 Points 75 badge 2x thumb
Agreed. Going 4G is not an option. Such an expensive phone should be able to handle LTE. It's ridiculous there's no response from Samsung.
Photo of BobTheElectrician

BobTheElectrician

  • 69,928 Points 50k badge 2x thumb
Photo of Michelle Minshall

Michelle Minshall

  • 344 Points 250 badge 2x thumb
Has anyone downloaded the new software update yet? 
I'm nervous too, after just having all these issues.
Photo of Gerry Hanlon

Gerry Hanlon

  • 2,868 Points 2k badge 2x thumb
I updated 2 of my phones today! Both S6's. One update was 277MB's and the other one was 97.70MB's! I'm so confused! LOL
Both seem to be fine though.Seem to be getting my texts on time,haven't tried calling with wifi on and off yet. 
Photo of Rara

Rara

  • 130 Points 100 badge 2x thumb
Better switch the network to WCDMA only and no problems after that.
Photo of Adam Tippett

Adam Tippett

  • 60 Points
I can't believe reading this... I'm glad I'm not alone.  Calls not coming in, and text's not coming in for several hours, or until I send myself a text, then they all come through (when texting myself even works that is...).  I'm with Rogers by the way with my S6.  My old phone was a cheap HTC and never had an issue, so I thought I would go with the great Galaxy S6 this time around, and this is what I get...  Brilliant...
(Edited)
Photo of Bobbi

Bobbi

  • 142 Points 100 badge 2x thumb
I have not had any issues since downloading the latest software update, about a week ago. Unfortunately, I did not even know there was an update until reading above posts. I then had to search for it in my settings, there was no notification that there were updates available. I am not the most tech savvy, and would appreciate some heads up that there are updates waiting.
Photo of Robert

Robert, Mobile Master

  • 109,588 Points 100k badge 2x thumb
If you updated a week ago, it means you already are on the latest update, right?
Photo of Terry Price

Terry Price

  • 70 Points
In last 3 weeks been having same problem. I have Samsung 6 on Rogers network. Did factory reset changed simple card same issue. Did notice when I changed the mobile network from lte. I started to receive messages from earlier in the day. I changed too Gsm/HSPA network.
Photo of Robert

Robert, Mobile Master

  • 109,588 Points 100k badge 2x thumb
Have you updated your phone to the latest update available?
Photo of Terry Price

Terry Price

  • 70 Points
Yes. I have.
Photo of Taylor Upshaw

Taylor Upshaw

  • 1,856 Points 1k badge 2x thumb
Has anyone tried contacting Samsung about this issue? It sounds like a fauly kernel in the new update. 
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
Samsung is working on a resolution.
Photo of Dacian Toncescu

Dacian Toncescu

  • 252 Points 250 badge 2x thumb
How do you know?
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
I do Tech Support for another Carrier and we have been notified that they are working with Samsung to resolve issue.   I'm sure all the Carriers are.   This issue is affecting all Carriers,  not just Koodo.
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
Actually,  I just found an update about this issue at mobilesyrup.com
http://mobilesyrup.com/2015/11/10/rogers-to-release-fix-for-problematic-galaxy-s6-android-5-1-1-upda...
Photo of Mandeep Khehra

Mandeep Khehra

  • 60 Points
I have 6s edge and it's been more than two weeks no incoming (reciving any calls) no texts going or coming either. I am with fido. Called them so many times,(my outgoing working perfectly) they said they will response me by week or two. I hate this ph now.
Anybody have same issue or any solution:(
Photo of Ashley Hernandez

Ashley Hernandez

  • 60 Points
Thank you so much this issue has been driving me crazy
Photo of Melissa .

Melissa .

  • 60 Points
I have an S6 Edge and this has been happening to me since I bought it, tired of getting angry messages from friends thinking I'm ignoring their calls!! No ringing, no missed call notifications, and delayed voicemails if any.  I am going to try changing the wi-fi settings to what was recommended and hopefully it works.
Photo of Mitchell Palmater

Mitchell Palmater

  • 12,976 Points 10k badge 2x thumb
check for software updates.
a fix did come in the form of a patch.
Photo of Greg Knierim

Greg Knierim

  • 70 Points
The problem still happens after the patch.  So try again.  I am able to do everything else (send texts, receive/send email, browser).  I cannot receive or make calls when this happens and has been happening for the last 5 months.  Restarting the phone always solves the problem.
Photo of Greg Knierim

Greg Knierim

  • 70 Points

Has it worked Melissa?

Photo of Lisa Dew

Lisa Dew

  • 210 Points 100 badge 2x thumb
I have a galaxy A5 and I'm having this issue. I don't have much data on my phone and don't feel I should have to shut off wifi to receive what I'm paying monthly to receive. I just joined koodo last month and am not too happy about this. Any news?