faulty button/link on self serve pre-authorized credit card payment page

  • 1
  • Question
  • Updated 4 years ago
  • Answered
On self-serve when trying to set up pre-authorized credit card payments, after filling in all of my info the "submit" button won't do anything, It's a dead button/link. I've tried from 2 different computers, anyone else notice this and can it get fixed ASAP?
Photo of Irish Stew

Irish Stew

  • 70 Points

Posted 4 years ago

  • 1
Photo of Rocky Balboa

Rocky Balboa

  • 20,414 Points 20k badge 2x thumb
There might be an issue not sure exactly. If you're having issues updating this I'd call customer service and they could update your payment method for you. Keep in mind the balance of the bill would have to be payed manually at which point the next months payment will be taken from the due date of your bill.
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
I was going to suggest clearing your cache/cookies but you've said you tried 2 different computers so I don't think that's the issue. I would call customer service and have them do it since you're having issues.

This conversation is no longer open for comments or replies.