False Advertising of Unlimited Picture Messaging

  • 7
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Why does Koodo advertise that "all Canada-wide plans include unlimited text and picture messaging", but if you have a smart phone, you can't actually send or receive and picture message without ALSO using data? I begrudgingly switched over to an android from a slide qwerty phone, not wanting to ever use data, with the same SIM and Canada Wide Talk and Text plan. I can no longer use picture messaging, even though it's still "included" in my plan. Really disappointed, I can't afford to pay more for a service that used to be included in my plan.
Photo of Lyzer

Lyzer

  • 140 Points 100 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 7
Photo of Humberto Giambrone

Humberto Giambrone

  • 4,900 Points 4k badge 2x thumb
This is the same for all carriers, but it is sort of an elephant in the room that is a continuous problem.

There may be a way around this for you depending on your Android as I recall, see this helpful post, take the time to go through it to see what people have said about it:
http://community.koodomobile.com/kood...
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
The only thing that Unlimited Messaging does, is remove the overage cost for sending picture messages. It has no bearing on the service actually working.

It's very common knowledge that on the HSPA network, MMS requires an active data connection. If you want to put the blame on anyone, put it on the ones that created the HSPA network.

It is actually stated that MMS requires an active data connection if you look under the nitty gritty section.
Photo of DJ

DJ

  • 792 Points 500 badge 2x thumb
This is correct. MMS requires data. This is true for all carriers. At least it was when I was with another carrier less than 8 months ago. Usually koodo provides 2gb data with the Canada wide plan so sending pictures should not cost you unless you send a lot. And if you have wifi it probably won't cost you at all because data is simply Internet access and wifi is Internet access.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
That is NOT correct. MMS needs the mobile data to be on for picture messages to work. There are NO CHARGES for any picture messages in Koodo's plans that have unlimited messaging as a feature no matter how many are sent or received. They will NOT work through wifi UNLESS mobile data is on as well.
Photo of Rocky Balboa

Rocky Balboa

  • 20,414 Points 20k badge 2x thumb
virtual star zaphod! Well worded
Photo of Rob Benn-Frenette

Rob Benn-Frenette

  • 80 Points 75 badge 2x thumb
I just randomly found this. I brought this to their attention via the CCTS. They claim I was the first and other ever tell them. Your post is years old. I doubt they didn't know before my call
Photo of Ivan

Ivan, Mobile Master

  • 96,292 Points 50k badge 2x thumb
What did you bring to their attention exactly? Data used for MMS is not billed. MMS is unlimited.
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Using your Picture Messaging without allowing access to Mobile Data by anything else.

Can you send regular text messages but not picture messages?

SIM CARD BASED phones require a data connection in order to send those messages. So if you have data turned off, or blocked, these messages won't go through. "But wait" you say "My plan includes unlimited text and picture messaging. I want to use it but I don't want data because I feel it's too expensive (or whatever)". The Mobile Masters have your solution below.

You can enable data by navigating Settings / Wireless and networking / Mobile Network

Make sure 'use packet data' or 'enable data' is checked.

If you have data blocked by Koodo you'll need to unblock it. You'll have to call customer service to have the block removed. Follow the methods below to ensure data is only available to picture messaging.

Setting up A Koodo phone for MMS with no additional Data Access
FOR ANDROID DEVICES -=-

First We need to do a little housekeeping. Navigate to your current messaging app and delete any picuture message you previously tried to send but have failed.

Next:

Navigate to Settings / Wireless controls / Mobile networks / access point names

METHOD 1.
Find the Koodo.sp Apn and tap it to open it. Some phones will allow you to edit this APN, for those phones which will not allow you to edit the default APN (I.E the Samsung Galaxy S2x), please skip to Method 2.

Tap APN type and change it so it reads only "mms" then tap the menu key and select save APN
once saved the 4g indicator should disappear. Please see: Note 1

METHOD 2

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: spp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC:
Proxy server:
Port:
MCC :
MNC :
APN type : default

For APN Type we use "default" for this example but if it doesn't work for you, go back and change it to "Internet"
Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.

On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) APN and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.
Reboot the phone (Shut it off and turn it back on)
Turn off your WiFi
Open your browser and attempt to access any webpage other than Google (google is normally cached). You should get a message that the page cannot be displayed.

Note 1: (For Everyone to read)
You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. The Same thing will happen when you get a picture message.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,838 Points 100k badge 2x thumb
You need to select the first apn that you made. If the Koodo apn defaults back to being selected, then your phone is one of those phones where this will not work.

As long as the Koodo apn isn't select, it shouldn't work/ be active.
(Edited)
Photo of Pesi

Pesi

  • 180 Points 100 badge 2x thumb
I'll try it right now. Thanks so much for the advice!
Photo of Pesi

Pesi

  • 180 Points 100 badge 2x thumb
...and of course, do we keep the "Allow Mobile Data" setting on all the time?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,838 Points 100k badge 2x thumb
Yes, but you should only see a connection when you send or receive a mms

If it works
Photo of Pesi

Pesi

  • 180 Points 100 badge 2x thumb
Seems to be working fine so far - thanks so much for your help and advice.
Photo of Pretty Smith

Pretty Smith

  • 60 Points
Hi...I am really has no knowledge about this stuff at all until I read this. So it looks stupid but I really need to know....lets say that I can use the mms using all the steps mentioned above, so am I able to browse using the wifi ? (since on the step 1 is said that TURN OFF WIFI ). Like others I don't have data on my phone but unlimited text and pic msg and only use the wifi access to browse....facebook, emails etc...Please somebody explain....many thanks and happy new year...
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,892 Points 100k badge 2x thumb
It says turn off your wifi before testing to make sure that you are testing the 3G connection. If wifi is connected, any online functions that are able to will use wifi, so the only way to verify that 3G access is down is to try it with wifi disconnected.
Photo of flyersfan

flyersfan

  • 1,654 Points 1k badge 2x thumb
Here's another option that a wise lady in this community gave me.

GO PREPAID!! Unlimited texting and MMS for $15/mo. If you need talk time, purchase a booster.

500 Anytime Minutes at 5¢/min for $25
100 Anytime Minutes at 10¢/min for $10
25 Anytime Minutes at 20¢/min for $5

As long as you are a prepaid customer, your unused minutes NEVER expire. And right now, there is a Limited time offer! Get 10% off your base plan each time it’s renewed when you have automatic top-ups on your account. It is something to consider. Check it out.
Photo of Some random Mobile Master

Some random Mobile Master, Mobile Master

  • 39,554 Points 20k badge 2x thumb
I think I have never agreed more with anyone before. Well said Sophia! And completely agreed! Typical users should not have to edit APNs to achieve desired effect.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Ummmmmmmm, ya you do.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
I've tried android firewalls and all kinds of shortcuts the only thing that works on some phones is editing the apn.
Photo of Some random Mobile Master

Some random Mobile Master, Mobile Master

  • 39,554 Points 20k badge 2x thumb
Well, yeah, I do have agreed as much with someone else before. Remember who? :oD
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
My post was in regards to the flyersfan post. Sorry guys :P

This conversation is no longer open for comments or replies.