Email to Text Message REQUIRES data?

  • 1
  • Question
  • Updated 7 months ago
  • Answered
Using Android 2.3.6: If I send a text message by sending an email to
10-digit-number@msg.koodomobile.com when data is turned OFF, it shows me the subject, Message size, date it expires and "Download" or "Reject" buttons but it's just simple (and very short) text from my Alarm company. The problem is that if data is turned off (which it will obviously always be when overseas) I basically don't get the text messages (or any audible alert that I have one). When I change to msg.telus.com it works perfectly with data off. While I know Koodo was Telus (with Telus scratched out and Koodo written in, e.g. another Telus "brand" is this still the case?) and is this a "safe" way to send these important messages or is there a danger that it will stop working someday? Is the msg.koodomobile.com email to text gateway broken (wrong) in that it always sends MMS as opposed to SMS?
Photo of Steve

Steve

  • 4,030 Points 4k badge 2x thumb

Posted 5 years ago

  • 1
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
It shouldn't matter, but if you would like the "correct" settings:

Setting up A Koodo phone for MMS with no additional Data Access
FOR ANDROID DEVICES

Navigate to Settings / Wireless controls / Mobile networks / access point names

METHOD 1.
Find the Koodo.sp Apn and tap it to open it. Some phones will allow you to edit this APN, for those phones which will not allow you to edit the default APN, please skip to Method 2.

Tap APN type and change it so it reads only "mms" then tap the menu key and select save APN
once saved the 4g indicator should disappear. Please see: Note 1

METHOD 2

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: spp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC:
Proxy server:
Port:
MCC :
MNC :
APN type :internet

Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.

On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.

Note 1:
You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Photo of Steve

Steve

  • 4,030 Points 4k badge 2x thumb
Ahmad: Thanks for your response but I think you may have missed the “essence” of my question. If I understand your response correctly this would cause normal data not to work? I do have a data plan and need to use it (but only in Canada so when outside the country I always turn data off (to avoid the sticker shock of surprise roaming data charges), or perhaps a clearer example is I turn data off (with a simple toggle widget) when it’s time to sleep so that there will be no incoming emails to disturb me but it is still important that I be able to receive (and be alerted by) normal text messages at these times. Another “concern” is that a foreign carrier may see the MMS data as simply data if someone were to send me a large picture in an MMS message so I kind of like the fact that MMS won’t work with data turned off but it seems the gateway @msg.koodomobile.com is “faulty” in that it always sends what should be a simple or more basic SMS text messages as an MMS message?
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,436 Points 100k badge 2x thumb
@msg.koodomobile.com will indeed always send messages as mms. This is how it was designed, it is not considered to be broken and therefore is unlikely to ever be 'fixed'. From what you have stated and what I have read before from other people messages will be delivered to koodo phones if sent through @msg.telus.com, so you'd be better off using that one instead.
Photo of Steve

Steve

  • 4,030 Points 4k badge 2x thumb
Thanks so much for that, that is what I will do.

Yes, I consider it "broken" because I used to have a W385 on Koodo that simply could not display an MMS text message that should have been sent an SMS text message (that it could display) so not knowing about the Telus alternative at the time it was "broken" in that it didn't work for me at all and technical support had no solution for me.
Photo of Mary Johnson

Mary Johnson

  • 166 Points 100 badge 2x thumb
Not sending SMS text messages via @msg.koodomobile.com means that it's broken.  If Koodo designed it that way they willingly and purposefully broke (or consciously crippled) functionality that life saving GPS (e.g. SPOT) use to text when calling for help.
Photo of Allan

Allan, Mobile Master

  • 61,750 Points 50k badge 2x thumb
If you don't like the functionality of @msg.koodomobile.com you can use @msg.telus.com which will send it as a sms instead.
Photo of brianjmurrell

brianjmurrell

  • 70 Points
I have to agree that always sending simple text messages received by e-mail out to the phone as an MMS is broken. It's text. It will go into a regular SMS just fine. Every other carrier doesn't seem to have a problem with this. Koodo is the only carrier I know of that sends even simple text messages as MMS just because they were sent by e-mail.
Photo of KaneSlavik

KaneSlavik

  • 6,464 Points 5k badge 2x thumb
It's not a text. When you send a text message to an email, it'll be converted to an MMS. And that's because it's not text message to text message. Text message sent to an email address is always identified as a MMS because email addresses are not sms.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 141,422 Points 100k badge 2x thumb
Saying something is broken because it does what it was designed to rather than what you want it to is like saying your car is broken because it doesn't fly. As prebiously stated, send the message to @msg.telus.com and it will be sent as basic sms.
Photo of Mary Johnson

Mary Johnson

  • 166 Points 100 badge 2x thumb
Timo: I have been emailing to ##########@msg.telus.com as well to see if it'll work.   No joy so far.  Koodo prepaid, celluar data off, wifi connection is active however.

Did find this page: https://www.koodomobile.com/send-a-message "Koodo’s Send a Message service is no longer offered. However, we’ve still got you covered since all our plans now include unlimited messaging.
Text away!"  

Perhaps disabled or crippled by design is a better wording than "broken". :)
Photo of Allan

Allan, Mobile Master

  • 59,194 Points 50k badge 2x thumb
To keep it all in one place at least:
https://community.koodomobile.com/koo...

This conversation is no longer open for comments or replies.