Easy roam not working after crossing from Ontario into New York although at@t shows up with signal strength

  • 1
  • Question
  • Updated 9 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Motorola phone, at@t,
Photo of arnold

arnold

  • 80 Points 75 badge 2x thumb
  • frustrating

Posted 9 months ago

  • 1
Photo of Camilo_A

Camilo_A

  • 31,746 Points 20k badge 2x thumb
Hi there...

Try to go into settings, Mobile networks and try to select manually another carrier to see if you pick up services...

But, what is it that you see? Emergency calls only? Are you able to do something with your phone? (text, call, internet)
Photo of Dennis

Dennis, Mobile Master

  • 196,120 Points 100k badge 2x thumb
Log into self serve and make sure the free International voice roaming and International data roaming are added to your account
Photo of Robert

Robert, Mobile Master

  • 106,940 Points 100k badge 2x thumb
Did you activate the "easyroam" option on your account?
Photo of arnold

arnold

  • 80 Points 75 badge 2x thumb
Hi there, thanks for getting back. Yes I did activate easy roam and no it never activated although I did get a koodo message saying it was on. Anyway it's past the 24 hour period now and so I don't want to pay. I find contacting koodo hard. Is there a way to get in touch w billing to ensure this is not on my account?
Thank you
A
Photo of Dennis

Dennis, Mobile Master

  • 196,120 Points 100k badge 2x thumb
It doesnt charge your account if you didnt use it.

Just check your next pdf invoice as regualr practice to make sure all is ok

This conversation is no longer open for comments or replies.